<!DOCTYPE html>
<html class="no-js mh-one-sb" lang="en-US">
<head>
<meta charset="UTF-8">
<meta name="viewport" content="width=device-width, initial-scale=1.0">
<link rel="profile" href="http://gmpg.org/xfn/11" />

	<!-- This site is optimized with the Yoast SEO plugin v14.1 - https://yoast.com/wordpress/plugins/seo/ -->
	<title>The 2020 COVID-19 (coronavirus) saga: The mid-May edition - blogHOUSTON</title>
	<meta name="description" content="Neal Meyer strolls the Galleria area, and shares his takeaways on the current local state of the coronavirus crisis." />
	<meta name="robots" content="index, follow" />
	<meta name="googlebot" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" />
	<meta name="bingbot" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" />
	<link rel="canonical" href="https://www.bloghouston.com/2020/05/the-2020-covid-19-coronavirus-saga-the-mid-may-edition/" />
	<meta property="og:locale" content="en_US" />
	<meta property="og:type" content="article" />
	<meta property="og:title" content="The 2020 COVID-19 (coronavirus) saga: The mid-May edition - blogHOUSTON" />
	<meta property="og:description" content="Neal Meyer strolls the Galleria area, and shares his takeaways on the current local state of the coronavirus crisis." />
	<meta property="og:url" content="https://www.bloghouston.com/2020/05/the-2020-covid-19-coronavirus-saga-the-mid-may-edition/" />
	<meta property="og:site_name" content="blogHOUSTON" />
	<meta property="article:publisher" content="https://www.facebook.com/blogHOUSTON" />
	<meta property="article:published_time" content="2020-05-17T15:00:09+00:00" />
	<meta property="article:modified_time" content="2020-05-17T15:41:05+00:00" />
	<meta property="og:image" content="https://www.bloghouston.com/wp-content/uploads/2020/03/houston-1402093_640.jpg" />
	<meta property="og:image:width" content="640" />
	<meta property="og:image:height" content="426" />
	<meta name="twitter:card" content="summary" />
	<meta name="twitter:creator" content="@blogHOUSTON" />
	<meta name="twitter:site" content="@blogHOUSTON" />
	<script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"https://www.bloghouston.com/#organization","name":"blogHOUSTON","url":"https://www.bloghouston.com/","sameAs":["https://www.facebook.com/blogHOUSTON","https://www.linkedin.com/company/bloghouston","https://twitter.com/blogHOUSTON"],"logo":{"@type":"ImageObject","@id":"https://www.bloghouston.com/#logo","inLanguage":"en-US","url":"https://www.bloghouston.com/wp-content/uploads/blogHOUSTON_logo.png","width":249,"height":100,"caption":"blogHOUSTON"},"image":{"@id":"https://www.bloghouston.com/#logo"}},{"@type":"WebSite","@id":"https://www.bloghouston.com/#website","url":"https://www.bloghouston.com/","name":"blogHOUSTON","description":"Houston&#039;s conservative alternative since 2004","publisher":{"@id":"https://www.bloghouston.com/#organization"},"potentialAction":[{"@type":"SearchAction","target":"https://www.bloghouston.com/?s={search_term_string}","query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://www.bloghouston.com/2020/05/the-2020-covid-19-coronavirus-saga-the-mid-may-edition/#primaryimage","inLanguage":"en-US","url":"https://www.bloghouston.com/wp-content/uploads/2020/03/houston-1402093_640.jpg","width":640,"height":426,"caption":"Image credit: Pixabay"},{"@type":"WebPage","@id":"https://www.bloghouston.com/2020/05/the-2020-covid-19-coronavirus-saga-the-mid-may-edition/#webpage","url":"https://www.bloghouston.com/2020/05/the-2020-covid-19-coronavirus-saga-the-mid-may-edition/","name":"The 2020 COVID-19 (coronavirus) saga: The mid-May edition - blogHOUSTON","isPartOf":{"@id":"https://www.bloghouston.com/#website"},"primaryImageOfPage":{"@id":"https://www.bloghouston.com/2020/05/the-2020-covid-19-coronavirus-saga-the-mid-may-edition/#primaryimage"},"datePublished":"2020-05-17T15:00:09+00:00","dateModified":"2020-05-17T15:41:05+00:00","description":"Neal Meyer strolls the Galleria area, and shares his takeaways on the current local state of the coronavirus crisis.","inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://www.bloghouston.com/2020/05/the-2020-covid-19-coronavirus-saga-the-mid-may-edition/"]}]},{"@type":"Article","@id":"https://www.bloghouston.com/2020/05/the-2020-covid-19-coronavirus-saga-the-mid-may-edition/#article","isPartOf":{"@id":"https://www.bloghouston.com/2020/05/the-2020-covid-19-coronavirus-saga-the-mid-may-edition/#webpage"},"author":{"@id":"https://www.bloghouston.com/#/schema/person/e946969dccf177135475743176e98ae6"},"headline":"The 2020 COVID-19 (coronavirus) saga: The mid-May edition","datePublished":"2020-05-17T15:00:09+00:00","dateModified":"2020-05-17T15:41:05+00:00","commentCount":0,"mainEntityOfPage":{"@id":"https://www.bloghouston.com/2020/05/the-2020-covid-19-coronavirus-saga-the-mid-may-edition/#webpage"},"publisher":{"@id":"https://www.bloghouston.com/#organization"},"image":{"@id":"https://www.bloghouston.com/2020/05/the-2020-covid-19-coronavirus-saga-the-mid-may-edition/#primaryimage"},"keywords":"coronavirus,COVID-19,Galleria,hygiene,mask,Neal Meyer,social distance,Westheimer","articleSection":"Commentary","inLanguage":"en-US","potentialAction":[{"@type":"CommentAction","name":"Comment","target":["https://www.bloghouston.com/2020/05/the-2020-covid-19-coronavirus-saga-the-mid-may-edition/#respond"]}]},{"@type":["Person"],"@id":"https://www.bloghouston.com/#/schema/person/e946969dccf177135475743176e98ae6","name":"Neal Meyer","image":{"@type":"ImageObject","@id":"https://www.bloghouston.com/#personlogo","inLanguage":"en-US","url":"https://secure.gravatar.com/avatar/fab45469b59e1ecbbb3e25a426385d3a?s=96&d=mm&r=g","caption":"Neal Meyer"}}]}</script>
	<!-- / Yoast SEO plugin. -->


<link rel='dns-prefetch' href='//use.fontawesome.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="blogHOUSTON &raquo; Feed" href="https://www.bloghouston.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="blogHOUSTON &raquo; Comments Feed" href="https://www.bloghouston.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="blogHOUSTON &raquo; The 2020 COVID-19 (coronavirus) saga: The mid-May edition Comments Feed" href="https://www.bloghouston.com/2020/05/the-2020-covid-19-coronavirus-saga-the-mid-may-edition/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.bloghouston.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=53beb039abc5bc0ba0c55aafbecaca64"}};
			/*! This file is auto-generated */
			!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='dashicons-css'  href='https://www.bloghouston.com/wp-includes/css/dashicons.min.css?ver=53beb039abc5bc0ba0c55aafbecaca64' type='text/css' media='all' />
<link rel='stylesheet' id='wpzoom-social-icons-academicons-css'  href='https://www.bloghouston.com/wp-content/plugins/social-icons-widget-by-wpzoom/assets/css/academicons.min.css?ver=1586739947' type='text/css' media='all' />
<link rel='stylesheet' id='wpzoom-social-icons-socicon-css'  href='https://www.bloghouston.com/wp-content/plugins/social-icons-widget-by-wpzoom/assets/css/socicon.css?ver=1586739947' type='text/css' media='all' />
<link rel='stylesheet' id='wpzoom-social-icons-font-awesome-5-css'  href='https://www.bloghouston.com/wp-content/plugins/social-icons-widget-by-wpzoom/assets/css/font-awesome-5.min.css?ver=1586739947' type='text/css' media='all' />
<link rel='stylesheet' id='wpzoom-social-icons-genericons-css'  href='https://www.bloghouston.com/wp-content/plugins/social-icons-widget-by-wpzoom/assets/css/genericons.css?ver=1586739947' type='text/css' media='all' />
<link rel='stylesheet' id='wp-block-library-css'  href='https://www.bloghouston.com/wp-includes/css/dist/block-library/style.min.css?ver=53beb039abc5bc0ba0c55aafbecaca64' type='text/css' media='all' />
<link rel='stylesheet' id='wpzoom-social-icons-block-style-css'  href='https://www.bloghouston.com/wp-content/plugins/social-icons-widget-by-wpzoom/block/dist/blocks.style.build.css?ver=1586739947' type='text/css' media='all' />
<link rel='stylesheet' id='wpsr_main_css-css'  href='https://www.bloghouston.com/wp-content/plugins/wp-socializer/public/css/wpsr.min.css?ver=5.2.1' type='text/css' media='all' />
<link rel='stylesheet' id='wpsr_sb_icon_css-css'  href='https://use.fontawesome.com/releases/v5.12.0/css/all.css?ver=5.2.1' type='text/css' media='all' />
<link rel='stylesheet' id='wordpress-popular-posts-css-css'  href='https://www.bloghouston.com/wp-content/plugins/wordpress-popular-posts/assets/css/wpp.css?ver=5.1.0' type='text/css' media='all' />
<link rel='stylesheet' id='mh-magazine-css'  href='https://www.bloghouston.com/wp-content/themes/mh-magazine/style.css?ver=3.9.5' type='text/css' media='all' />
<link rel='stylesheet' id='mh-font-awesome-css'  href='https://www.bloghouston.com/wp-content/themes/mh-magazine/includes/font-awesome.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='mh-google-fonts-css'  href='https://fonts.googleapis.com/css?family=Open+Sans:300,400,400italic,600,700' type='text/css' media='all' />
<link rel='stylesheet' id='wpzoom-social-icons-font-awesome-3-css'  href='https://www.bloghouston.com/wp-content/plugins/social-icons-widget-by-wpzoom/assets/css/font-awesome-3.min.css?ver=1586739947' type='text/css' media='all' />
<script type='text/javascript' src='https://www.bloghouston.com/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp'></script>
<script type='text/javascript' src='https://www.bloghouston.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var wpp_params = {"sampling_active":"0","sampling_rate":"100","ajax_url":"https:\/\/www.bloghouston.com\/wp-json\/wordpress-popular-posts\/v1\/popular-posts","ID":"11213","token":"83aacc8bb3","debug":""};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.bloghouston.com/wp-content/plugins/wordpress-popular-posts/assets/js/wpp-5.0.0.min.js?ver=5.1.0'></script>
<script type='text/javascript' src='https://www.bloghouston.com/wp-content/themes/mh-magazine/js/scripts.js?ver=3.9.5'></script>
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.bloghouston.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.bloghouston.com/wp-includes/wlwmanifest.xml" /> 

<link rel='shortlink' href='https://www.bloghouston.com/?p=11213' />
<link rel="alternate" type="application/json+oembed" href="https://www.bloghouston.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.bloghouston.com%2F2020%2F05%2Fthe-2020-covid-19-coronavirus-saga-the-mid-may-edition%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.bloghouston.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.bloghouston.com%2F2020%2F05%2Fthe-2020-covid-19-coronavirus-saga-the-mid-may-edition%2F&#038;format=xml" />
<script type="text/javascript">
           var ajaxurl = "https://www.bloghouston.com/wp-admin/admin-ajax.php";
         </script><!-- This code is added by WP Analytify (3.0.0) https://analytify.io/downloads/analytify-wordpress-plugin/ !-->				 <script>
				 (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
					 (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
					 m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
				 })

				 (window,document,'script','//www.google-analytics.com/analytics.js','ga');
				 	ga('create', 'UA-135422-3', 'auto');ga('send', 'pageview');				 </script>

				 <!-- This code is added by WP Analytify (3.0.0) !--><style type="text/css">
.mh-navigation li:hover, .mh-navigation ul li:hover > ul, .mh-main-nav-wrap, .mh-main-nav, .mh-social-nav li a:hover, .entry-tags li, .mh-slider-caption, .mh-widget-layout8 .mh-widget-title .mh-footer-widget-title-inner, .mh-widget-col-1 .mh-slider-caption, .mh-widget-col-1 .mh-posts-lineup-caption, .mh-carousel-layout1, .mh-spotlight-widget, .mh-social-widget li a, .mh-author-bio-widget, .mh-footer-widget .mh-tab-comment-excerpt, .mh-nip-item:hover .mh-nip-overlay, .mh-widget .tagcloud a, .mh-footer-widget .tagcloud a, .mh-footer, .mh-copyright-wrap, input[type=submit]:hover, #infinite-handle span:hover { background: #5e5e5e; }
.mh-extra-nav-bg { background: rgba(94, 94, 94, 0.2); }
.mh-slider-caption, .mh-posts-stacked-title, .mh-posts-lineup-caption { background: #5e5e5e; background: rgba(94, 94, 94, 0.8); }
@media screen and (max-width: 900px) { #mh-mobile .mh-slider-caption, #mh-mobile .mh-posts-lineup-caption { background: rgba(94, 94, 94, 1); } }
.slicknav_menu, .slicknav_nav ul, #mh-mobile .mh-footer-widget .mh-posts-stacked-overlay { border-color: #5e5e5e; }
.mh-copyright, .mh-copyright a { color: #fff; }
.mh-widget-layout4 .mh-widget-title { background: #0071bc; background: rgba(0, 113, 188, 0.6); }
.mh-preheader, .mh-wide-layout .mh-subheader, .mh-ticker-title, .mh-main-nav li:hover, .mh-footer-nav, .slicknav_menu, .slicknav_btn, .slicknav_nav .slicknav_item:hover, .slicknav_nav a:hover, .mh-back-to-top, .mh-subheading, .entry-tags .fa, .entry-tags li:hover, .mh-widget-layout2 .mh-widget-title, .mh-widget-layout4 .mh-widget-title-inner, .mh-widget-layout4 .mh-footer-widget-title, .mh-widget-layout5 .mh-widget-title-inner, .mh-widget-layout6 .mh-widget-title, #mh-mobile .flex-control-paging li a.flex-active, .mh-image-caption, .mh-carousel-layout1 .mh-carousel-caption, .mh-tab-button.active, .mh-tab-button.active:hover, .mh-footer-widget .mh-tab-button.active, .mh-social-widget li:hover a, .mh-footer-widget .mh-social-widget li a, .mh-footer-widget .mh-author-bio-widget, .tagcloud a:hover, .mh-widget .tagcloud a:hover, .mh-footer-widget .tagcloud a:hover, .mh-posts-stacked-item .mh-meta, .page-numbers:hover, .mh-loop-pagination .current, .mh-comments-pagination .current, .pagelink, a:hover .pagelink, input[type=submit], #infinite-handle span { background: #0071bc; }
.mh-main-nav-wrap .slicknav_nav ul, blockquote, .mh-widget-layout1 .mh-widget-title, .mh-widget-layout3 .mh-widget-title, .mh-widget-layout5 .mh-widget-title, .mh-widget-layout8 .mh-widget-title:after, #mh-mobile .mh-slider-caption, .mh-carousel-layout1, .mh-spotlight-widget, .mh-author-bio-widget, .mh-author-bio-title, .mh-author-bio-image-frame, .mh-video-widget, .mh-tab-buttons, textarea:hover, input[type=text]:hover, input[type=email]:hover, input[type=tel]:hover, input[type=url]:hover { border-color: #0071bc; }
.mh-header-tagline, .mh-dropcap, .mh-carousel-layout1 .flex-direction-nav a, .mh-carousel-layout2 .mh-carousel-caption, .mh-posts-digest-small-category, .mh-posts-lineup-more, .bypostauthor .fn:after, .mh-comment-list .comment-reply-link:before, #respond #cancel-comment-reply-link:before { color: #0071bc; }
.mh-subheader, .page-numbers, a .pagelink, .mh-widget-layout3 .mh-widget-title, .mh-widget .search-form, .mh-tab-button, .mh-tab-content, .mh-nip-widget, .mh-magazine-facebook-page-widget, .mh-social-widget, .mh-posts-horizontal-widget, .mh-ad-spot, .mh-info-spot { background: #b3b3b3; }
.mh-tab-post-item { border-color: rgba(255, 255, 255, 0.3); }
.mh-tab-comment-excerpt { background: rgba(255, 255, 255, 0.6); }
.entry-content a { color: #0071bc; }
a:hover, .entry-content a:hover, #respond a:hover, #respond #cancel-comment-reply-link:hover, #respond .logged-in-as a:hover, .mh-comment-list .comment-meta a:hover, .mh-ping-list .mh-ping-item a:hover, .mh-meta a:hover, .mh-breadcrumb a:hover, .mh-tabbed-widget a:hover { color: #0071bc; }
</style>
<!--[if lt IE 9]>
<script src="https://www.bloghouston.com/wp-content/themes/mh-magazine/js/css3-mediaqueries.js"></script>
<![endif]-->
<link rel="icon" href="https://www.bloghouston.com/wp-content/uploads/cropped-favicon_bh2019-1-32x32.png" sizes="32x32" />
<link rel="icon" href="https://www.bloghouston.com/wp-content/uploads/cropped-favicon_bh2019-1-192x192.png" sizes="192x192" />
<link rel="apple-touch-icon" href="https://www.bloghouston.com/wp-content/uploads/cropped-favicon_bh2019-1-180x180.png" />
<meta name="msapplication-TileImage" content="https://www.bloghouston.com/wp-content/uploads/cropped-favicon_bh2019-1-270x270.png" />
		<style type="text/css" id="wp-custom-css">
			#col1 ul, #col2 ul, #col3 ul {margin-left: 12px; padding-left: 6px; padding-right: 18px}
#col1 li, #col2 li, #col3 li {font-size: 12px; line-height: 130%; margin-bottom: 8px}
#col1 h3 {padding-top:15px}
#col2 h3 {padding-top:15px}
#col3 h3 {padding-top:15px}
#better_rss_widget-12 li {font-weight: 700; padding: 5px 0; border-bottom: 1px dotted #ebebeb; }
.wpp-list li {font-weight: 700; padding: 5px 0; border-bottom: 1px dotted #ebebeb; }
#linkcat-8 li {font-weight: 700; padding: 5px 0; border-bottom: 1px dotted #ebebeb; }
.zoom-social-icons-widget {padding-bottom: 18px;border-bottom: 1px dotted #ebebeb;}

#vf-widget-discussions li {font-weight: 700; padding: 5px 0; border-bottom: 1px dotted #ebebeb; }
blockquote {font-style:normal; font-size: 14px; font-size: 0.850rem; line-height: 1.5; margin-left: 25px}		</style>
		</head>
<body id="mh-mobile" class="post-template-default single single-post postid-11213 single-format-standard wp-custom-logo mh-boxed-layout mh-right-sb mh-loop-layout1 mh-widget-layout5" itemscope="itemscope" itemtype="https://schema.org/WebPage">
<div class="mh-container mh-container-outer">
<div class="mh-header-nav-mobile clearfix"></div>
	<div class="mh-preheader">
    	<div class="mh-container mh-container-inner mh-row clearfix">
							<div class="mh-header-bar-content mh-header-bar-top-left mh-col-2-3 clearfix">
									</div>
								</div>
	</div>
<header class="mh-header" itemscope="itemscope" itemtype="https://schema.org/WPHeader">
	<div class="mh-container mh-container-inner clearfix">
		<div class="mh-custom-header clearfix">
<div class="mh-header-columns mh-row clearfix">
<div class="mh-col-1-1 mh-site-identity">
<div class="mh-site-logo" role="banner" itemscope="itemscope" itemtype="https://schema.org/Brand">
<a href="https://www.bloghouston.com/" class="custom-logo-link" rel="home"><img width="249" height="100" src="https://www.bloghouston.com/wp-content/uploads/blogHOUSTON_logo.png" class="custom-logo" alt="blogHOUSTON logo" /></a></div>
</div>
</div>
</div>
	</div>
	<div class="mh-main-nav-wrap">
		<nav class="mh-navigation mh-main-nav mh-container mh-container-inner clearfix" itemscope="itemscope" itemtype="https://schema.org/SiteNavigationElement">
			<div class="menu-main-container"><ul id="menu-main" class="menu"><li id="menu-item-75" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-75"><a href="https://www.bloghouston.com">Front Page</a></li>
<li id="menu-item-83" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-83"><a title="Articles published by blogHOUSTON">Sections</a>
<ul class="sub-menu">
	<li id="menu-item-9253" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-9253"><a href="https://www.bloghouston.com/section/linkposts/">Around The Web</a></li>
	<li id="menu-item-9250" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-9250"><a href="https://www.bloghouston.com/section/articles/commentary/">Commentary</a></li>
	<li id="menu-item-9251" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-9251"><a href="https://www.bloghouston.com/section/articles/guest-commentary/">Guest Commentary</a></li>
	<li id="menu-item-9256" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-9256"><a href="https://www.bloghouston.com/section/brief/">In Brief</a></li>
	<li id="menu-item-9254" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-9254"><a href="https://www.bloghouston.com/section/news-releases/">News Releases</a></li>
</ul>
</li>
<li id="menu-item-6695" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-6695"><a title="Chronological archives of articles on blogHOUSTON" href="https://www.bloghouston.com/archives/">Archives</a></li>
<li id="menu-item-9432" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-9432"><a href="https://www.bloghouston.com/discussions/">Forum</a></li>
<li id="menu-item-71" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-71"><a href="https://www.bloghouston.com/about/">About</a></li>
<li id="menu-item-70" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-70"><a href="https://www.bloghouston.com/headlines/">Headlines</a></li>
</ul></div>		</nav>
	</div>
	</header>
	<div class="mh-subheader">
		<div class="mh-container mh-container-inner mh-row clearfix">
										<div class="mh-header-bar-content mh-header-bar-bottom-right mh-col-1-3 clearfix">
											<aside class="mh-header-search mh-header-search-bottom">
							<form role="search" method="get" class="search-form" action="https://www.bloghouston.com/">
				<label>
					<span class="screen-reader-text">Search for:</span>
					<input type="search" class="search-field" placeholder="Search &hellip;" value="" name="s" />
				</label>
				<input type="submit" class="search-submit" value="Search" />
			</form>						</aside>
									</div>
					</div>
	</div>
<div class="mh-wrapper clearfix">
	<div class="mh-main clearfix">
		<div id="main-content" class="mh-content" role="main" itemprop="mainContentOfPage"><nav class="mh-breadcrumb" itemscope itemtype="http://schema.org/BreadcrumbList"><span itemprop="itemListElement" itemscope itemtype="http://schema.org/ListItem"><a href="https://www.bloghouston.com" itemprop="item"><span itemprop="name">Home</span></a><meta itemprop="position" content="1" /></span><span class="mh-breadcrumb-delimiter"><i class="fa fa-angle-right"></i></span><a href="https://www.bloghouston.com/section/articles/">Articles</a><span class="mh-breadcrumb-delimiter"><i class="fa fa-angle-right"></i></span><span itemprop="itemListElement" itemscope itemtype="http://schema.org/ListItem"><a href="https://www.bloghouston.com/section/articles/commentary/" itemprop="item"><span itemprop="name">Commentary</span></a><meta itemprop="position" content="2" /></span><span class="mh-breadcrumb-delimiter"><i class="fa fa-angle-right"></i></span>The 2020 COVID-19 (coronavirus) saga: The mid-May edition</nav>
<article id="post-11213" class="post-11213 post type-post status-publish format-standard has-post-thumbnail hentry category-commentary tag-coronavirus tag-covid-19 tag-galleria tag-hygiene tag-mask tag-neal-meyer tag-social-distance tag-westheimer">
	<header class="entry-header clearfix"><h1 class="entry-title">The 2020 COVID-19 (coronavirus) saga: The mid-May edition</h1><div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://www.bloghouston.com/2020/05/">May 17, 2020</a></span>
<span class="entry-meta-author author vcard"><i class="fa fa-user"></i><a class="fn" href="https://www.bloghouston.com/author/neal/">Neal Meyer</a></span>
<span class="entry-meta-categories"><i class="fa fa-folder-open-o"></i><a href="https://www.bloghouston.com/section/articles/commentary/" rel="category tag">Commentary</a></span>
</div>
	</header>
		<div class="entry-content clearfix">
<figure class="entry-thumbnail">
<img src="https://www.bloghouston.com/wp-content/uploads/2020/03/houston-1402093_640-640x381.jpg" alt="" title="houston-1402093_640" />
<figcaption class="wp-caption-text">Image credit: Pixabay</figcaption>
</figure>
<p>It&#8217;s been a few weeks since I posted <a href="https://www.bloghouston.com/2020/04/the-2020-covid-19-coronavirus-saga-westheimer-the-ever-shovel-ready-road/">my last epistle</a> on the coronavirus event, as seen from the ground in H-Town. This is an update of a few odds and ends I&#8217;ve witnessed over the past two weeks or so.</p>
<p>I went out on a 2 1/2 hour walk around the Galleria area some evenings ago. While out there, it was rather eerie and quiet, which was not a surprise, but I did notice one thing that was very interesting. While out walking, I started to notice how many businesses of all kinds still had their electric signage lit up at the place of business. Of the hundreds of businesses I passed by during my 7 1/2 mile stroll, I noticed perhaps eight or nine whose signage was not lit up. I&#8217;ve been following what some of my social media friends around the country have been saying about what is happening around them, noting how businesses where they are have been closing one by one. After my walk around the Galleria area, it became clear that, two months into this event, Westheimer is still holding up. And that is a good thing.</p>
<p>When I&#8217;ve been out in public, I&#8217;ve been struck by when people wear masks and when they don&#8217;t. I&#8217;ve also been watching when people practice social distancing and when they don&#8217;t. Most people who are grocery shopping are wearing masks, but do not really seem to mind when other shoppers get <em>within range</em> of them. I had some repair work done on my vehicle, and nobody at the repair shop seemed to really care too much about either wearing masks or practicing social distancing. And yes, County Judge Hidalgo&#8217;s orders are still in effect, even if they aren&#8217;t being widely enforced.</p>
<p>When confronted with crises, republics and democracies tend to muddle their way through them. I&#8217;ve been thinking for some weeks that this is what is happening with this coronavirus event. One local acquaintance, whom I&#8217;ve known for some twenty years now, is crying for the government to pay for everyone to get masks. In the meantime, I was at a restaurant/saloon the other night, and couldn&#8217;t help but notice the cute face mask that the young lady who delivered my food to me was wearing. Another patron asked her where she got it, and she said she picked it up at a local Chevron gas station for $5. Protective gear is beginning to become more widely available if you&#8217;re really looking for it.</p>
<p>Other than that, I&#8217;ve put on a few pounds from ordering take out food from local restaurants far more often than I normally do. It really shouldn&#8217;t be too much to ask to wash your hands regularly, wear a face mask in public, and to be courteous about social distancing, while at the same time opening up the economy in a judicious way and getting people back to work.</p>
<p>Oh, and at this point, I&#8217;m still employed. I lost my longtime job, which I held for 23 years, about 28 months ago. I&#8217;ll find out my fate concerning my new job at the end of this month. In the meantime, <a href="https://en.wikipedia.org/wiki/Peggy_Noonan">Peggy Noonan&#8217;s</a> recent write up in the <a href="https://www.wsj.com/">Wall Street Journal</a> concerning <a href="https://www.wsj.com/articles/scenes-from-the-class-struggle-in-lockdown-11589498276?mod=djemalertNEWS">the class struggle going on in America over this event</a> is worth your time to read if you&#8217;re looking for the politics in all of this.</p>
<p>Keep your chin up.</p>
<div class="wp-socializer wpsr-buttons "><div class="wpsr-btn"><div class="socializer sr-popup sr-32px sr-opacity sr-pad"><span class="sr-facebook"><a rel="nofollow" href="https://www.facebook.com/share.php?u=https://www.bloghouston.com/2020/05/the-2020-covid-19-coronavirus-saga-the-mid-may-edition/" target="_blank"  title="Share this on Facebook"  style="color: #ffffff"><i class="fab fa-facebook-f"></i></a></span>
<span class="sr-twitter"><a rel="nofollow" href="https://twitter.com/intent/tweet?text=The+2020+COVID-19+%28coronavirus%29+saga%3A+The+mid-May+edition%20-%20https://www.bloghouston.com/2020/05/the-2020-covid-19-coronavirus-saga-the-mid-may-edition/%20" target="_blank"  title="Tweet this !"  style="color: #ffffff"><i class="fab fa-twitter"></i></a></span>
<span class="sr-linkedin"><a rel="nofollow" href="https://www.linkedin.com/sharing/share-offsite/?url=https://www.bloghouston.com/2020/05/the-2020-covid-19-coronavirus-saga-the-mid-may-edition/" target="_blank"  title="Add this to LinkedIn"  style="color: #ffffff"><i class="fab fa-linkedin-in"></i></a></span>
<span class="sr-reddit"><a rel="nofollow" href="https://reddit.com/submit?url=https://www.bloghouston.com/2020/05/the-2020-covid-19-coronavirus-saga-the-mid-may-edition/&amp;title=The+2020+COVID-19+%28coronavirus%29+saga%3A+The+mid-May+edition" target="_blank"  title="Submit this to Reddit"  style="color: #ffffff"><i class="fab fa-reddit-alien"></i></a></span>
<span class="sr-email"><a rel="nofollow" href="mailto:?to=&amp;subject=The 2020 COVID-19 (coronavirus) saga: The mid-May edition&amp;body=Neal Meyer strolls the Galleria area, and shares his takeaways on the current local state of the cor%20-%20https://www.bloghouston.com/2020/05/the-2020-covid-19-coronavirus-saga-the-mid-may-edition/" target="_blank"  title="Email this "  style="color: #ffffff"><i class="fa fa-envelope"></i></a></span>
<span class="sr-print"><a rel="nofollow" href="https://www.printfriendly.com/print?url=https://www.bloghouston.com/2020/05/the-2020-covid-19-coronavirus-saga-the-mid-may-edition/" target="_blank"  title="Print this article "  style="color: #ffffff"><i class="fa fa-print"></i></a></span>
<span class="sr-pdf"><a rel="nofollow" href="https://www.printfriendly.com/print?url=https://www.bloghouston.com/2020/05/the-2020-covid-19-coronavirus-saga-the-mid-may-edition/" target="_blank"  title="Convert to PDF"  style="color: #ffffff"><i class="fa fa-file-pdf"></i></a></span></div></div></div>	</div></article><nav class="mh-post-nav mh-row clearfix" itemscope="itemscope" itemtype="https://schema.org/SiteNavigationElement">
<div class="mh-col-1-2 mh-post-nav-item mh-post-nav-prev">
<a href="https://www.bloghouston.com/2020/05/weekend-brunch-for-10-may-2020/" rel="prev"><img width="80" height="60" src="https://www.bloghouston.com/wp-content/uploads/2020/05/DrJosephVaron_fb_20200510-80x60.jpg" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image" alt="" srcset="https://www.bloghouston.com/wp-content/uploads/2020/05/DrJosephVaron_fb_20200510-80x60.jpg 80w, https://www.bloghouston.com/wp-content/uploads/2020/05/DrJosephVaron_fb_20200510-678x503.jpg 678w, https://www.bloghouston.com/wp-content/uploads/2020/05/DrJosephVaron_fb_20200510-326x245.jpg 326w" sizes="(max-width: 80px) 100vw, 80px" /><span>Previous</span><p>Weekend brunch for 10 May 2020</p></a></div>
</nav>
<section class="mh-related-content">
<h3 class="mh-widget-title mh-related-content-title">
<span class="mh-widget-title-inner">Related Articles</span></h3>
<div class="mh-related-wrap mh-row clearfix">
<div class="mh-col-1-3 mh-posts-grid-col clearfix">
<article class="post-11045 format-standard mh-posts-grid-item clearfix">
	<figure class="mh-posts-grid-thumb">
		<a class="mh-thumb-icon mh-thumb-icon-small-mobile" href="https://www.bloghouston.com/2020/03/one-way-to-help-halt-covid-19-temporarily-shut-down-metro/" title="One way to help halt COVID-19: Temporarily shut down METRO"><img width="326" height="245" src="https://www.bloghouston.com/wp-content/uploads/2020/03/Swine_Flu_Masked_Train_Passengers_in_Mexico_City_Eneas-De-Troya-flickr-CC-BY-20-326x245.jpg" class="attachment-mh-magazine-medium size-mh-magazine-medium wp-post-image" alt="" srcset="https://www.bloghouston.com/wp-content/uploads/2020/03/Swine_Flu_Masked_Train_Passengers_in_Mexico_City_Eneas-De-Troya-flickr-CC-BY-20-326x245.jpg 326w, https://www.bloghouston.com/wp-content/uploads/2020/03/Swine_Flu_Masked_Train_Passengers_in_Mexico_City_Eneas-De-Troya-flickr-CC-BY-20-80x60.jpg 80w" sizes="(max-width: 326px) 100vw, 326px" />		</a>
					<div class="mh-image-caption mh-posts-grid-caption">
				Commentary			</div>
			</figure>
	<h3 class="entry-title mh-posts-grid-title">
		<a href="https://www.bloghouston.com/2020/03/one-way-to-help-halt-covid-19-temporarily-shut-down-metro/" title="One way to help halt COVID-19: Temporarily shut down METRO" rel="bookmark">
			One way to help halt COVID-19: Temporarily shut down METRO		</a>
	</h3>
	<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://www.bloghouston.com/2020/03/">March 18, 2020</a></span>
<span class="entry-meta-author author vcard"><i class="fa fa-user"></i><a class="fn" href="https://www.bloghouston.com/author/neal/">Neal Meyer</a></span>
<span class="entry-meta-categories"><i class="fa fa-folder-open-o"></i><a href="https://www.bloghouston.com/section/articles/commentary/" rel="category tag">Commentary</a></span>
</div>
	<div class="mh-posts-grid-excerpt clearfix">
		<div class="mh-excerpt"><p>Neal Meyer argues that in the interest of stopping the spread of COVID-19, METRO should be shut down temporarily. <a class="mh-excerpt-more" href="https://www.bloghouston.com/2020/03/one-way-to-help-halt-covid-19-temporarily-shut-down-metro/" title="One way to help halt COVID-19: Temporarily shut down METRO"></a></p>
</div>	</div>
</article></div>
<div class="mh-col-1-3 mh-posts-grid-col clearfix">
<article class="post-11047 format-standard mh-posts-grid-item clearfix">
	<figure class="mh-posts-grid-thumb">
		<a class="mh-thumb-icon mh-thumb-icon-small-mobile" href="https://www.bloghouston.com/2020/03/weekend-brunch-for-15-march-2020/" title="Weekend Brunch for 15 March 2020"><img width="326" height="245" src="https://www.bloghouston.com/wp-content/uploads/2020/03/Flatten-the-curve_npr-326x245.jpg" class="attachment-mh-magazine-medium size-mh-magazine-medium wp-post-image" alt="" srcset="https://www.bloghouston.com/wp-content/uploads/2020/03/Flatten-the-curve_npr-326x245.jpg 326w, https://www.bloghouston.com/wp-content/uploads/2020/03/Flatten-the-curve_npr-80x60.jpg 80w" sizes="(max-width: 326px) 100vw, 326px" />		</a>
					<div class="mh-image-caption mh-posts-grid-caption">
				Around The Web			</div>
			</figure>
	<h3 class="entry-title mh-posts-grid-title">
		<a href="https://www.bloghouston.com/2020/03/weekend-brunch-for-15-march-2020/" title="Weekend Brunch for 15 March 2020" rel="bookmark">
			Weekend Brunch for 15 March 2020		</a>
	</h3>
	<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://www.bloghouston.com/2020/03/">March 15, 2020</a></span>
<span class="entry-meta-author author vcard"><i class="fa fa-user"></i><a class="fn" href="https://www.bloghouston.com/author/kevin/">Kevin Whited</a></span>
<span class="entry-meta-categories"><i class="fa fa-folder-open-o"></i><a href="https://www.bloghouston.com/section/linkposts/" rel="category tag">Around The Web</a></span>
</div>
	<div class="mh-posts-grid-excerpt clearfix">
		<div class="mh-excerpt"><p>The Houston area belatedly comes to grips with the threat of COVID-19; City finances remain shaky; The area&#8217;s top industry reels; various Houston Way updates; and more! <a class="mh-excerpt-more" href="https://www.bloghouston.com/2020/03/weekend-brunch-for-15-march-2020/" title="Weekend Brunch for 15 March 2020"></a></p>
</div>	</div>
</article></div>
<div class="mh-col-1-3 mh-posts-grid-col clearfix">
<article class="post-11169 format-standard mh-posts-grid-item clearfix">
	<figure class="mh-posts-grid-thumb">
		<a class="mh-thumb-icon mh-thumb-icon-small-mobile" href="https://www.bloghouston.com/2020/04/weekend-brunch-for-19-april-2020/" title="Weekend brunch for 19 April 2020"><img width="326" height="245" src="https://www.bloghouston.com/wp-content/uploads/2020/04/hand-disinfection-4954840_640-326x245.jpg" class="attachment-mh-magazine-medium size-mh-magazine-medium wp-post-image" alt="" srcset="https://www.bloghouston.com/wp-content/uploads/2020/04/hand-disinfection-4954840_640-326x245.jpg 326w, https://www.bloghouston.com/wp-content/uploads/2020/04/hand-disinfection-4954840_640-80x60.jpg 80w" sizes="(max-width: 326px) 100vw, 326px" />		</a>
					<div class="mh-image-caption mh-posts-grid-caption">
				Around The Web			</div>
			</figure>
	<h3 class="entry-title mh-posts-grid-title">
		<a href="https://www.bloghouston.com/2020/04/weekend-brunch-for-19-april-2020/" title="Weekend brunch for 19 April 2020" rel="bookmark">
			Weekend brunch for 19 April 2020		</a>
	</h3>
	<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://www.bloghouston.com/2020/04/">April 19, 2020</a></span>
<span class="entry-meta-author author vcard"><i class="fa fa-user"></i><a class="fn" href="https://www.bloghouston.com/author/kevin/">Kevin Whited</a></span>
<span class="entry-meta-categories"><i class="fa fa-folder-open-o"></i><a href="https://www.bloghouston.com/section/linkposts/" rel="category tag">Around The Web</a></span>
</div>
	<div class="mh-posts-grid-excerpt clearfix">
		<div class="mh-excerpt"><p>The coronavirus may well have escaped a Wuhan virology lab; The coming economic downturn (and what follows); The &#8220;Racist Houston&#8221; anecdotes return; and more! <a class="mh-excerpt-more" href="https://www.bloghouston.com/2020/04/weekend-brunch-for-19-april-2020/" title="Weekend brunch for 19 April 2020"></a></p>
</div>	</div>
</article></div>
</div>
</section>
<div id="vanilla-comments"></div>
<script type="text/javascript">
var vanilla_forum_url = 'https://www.bloghouston.com/forum'; // Required: the full http url & path to your vanilla forum
var vanilla_identifier = '11213'; // Required: your unique identifier for the content being commented on
var vanilla_url = 'https://www.bloghouston.com/2020/05/the-2020-covid-19-coronavirus-saga-the-mid-may-edition/'; // Current page's url
var vanilla_category_id = '7'; // Embed comments in this category
(function() {
	var vanilla = document.createElement('script');
	vanilla.type = 'text/javascript';
	var timestamp = new Date().getTime();
	vanilla.src = vanilla_forum_url + '/js/embed.js';
	(document.getElementsByTagName('head')[0] || document.getElementsByTagName('body')[0]).appendChild(vanilla);
})();
</script>
<noscript>Please enable JavaScript to view the <a href="http://vanillaforums.com/?ref_noscript">comments powered by Vanilla.</a></noscript>
<div class="vanilla-credit"><a class="vanilla-anchor" href="http://vanillaforums.com">Comments by <span class="vanilla-logo">Vanilla</span></a></div>
		</div>
			<aside class="mh-widget-col-1 mh-sidebar" itemscope="itemscope" itemtype="https://schema.org/WPSideBar"><div id="zoom-social-icons-widget-3" class="mh-widget zoom-social-icons-widget"><h4 class="mh-widget-title"><span class="mh-widget-title-inner">Stay Connected</span></h4>
        
        <ul class="zoom-social-icons-list zoom-social-icons-list--with-canvas zoom-social-icons-list--rounded zoom-social-icons-list--no-labels">

            
                                <li class="zoom-social_icons-list__item">
                    <a class="zoom-social_icons-list__link"
                       href="https://fb.me/blogHOUSTON"  >
                                                                        
                                                    <span class="screen-reader-text">facebook</span>
                        
                        <span class="zoom-social_icons-list-span socicon socicon-facebook" data-hover-rule="background-color" data-hover-color="#3b5998" style="background-color : #3b5998; font-size: 36px; padding:4px" ></span>

                                            </a>
                </li>

            
                                <li class="zoom-social_icons-list__item">
                    <a class="zoom-social_icons-list__link"
                       href="https://twitter.com/blogHOUSTON"  >
                                                                        
                                                    <span class="screen-reader-text">twitter</span>
                        
                        <span class="zoom-social_icons-list-span socicon socicon-twitter" data-hover-rule="background-color" data-hover-color="#55acee" style="background-color : #55acee; font-size: 36px; padding:4px" ></span>

                                            </a>
                </li>

            
                                <li class="zoom-social_icons-list__item">
                    <a class="zoom-social_icons-list__link"
                       href="https://www.linkedin.com/company/18929729"  >
                                                                        
                                                    <span class="screen-reader-text">linkedin</span>
                        
                        <span class="zoom-social_icons-list-span socicon socicon-linkedin" data-hover-rule="background-color" data-hover-color="#3371b7" style="background-color : #3371b7; font-size: 36px; padding:4px" ></span>

                                            </a>
                </li>

            
                                <li class="zoom-social_icons-list__item">
                    <a class="zoom-social_icons-list__link"
                       href="https://feeds.feedburner.com/bHmain"  >
                                                                        
                                                    <span class="screen-reader-text">rss</span>
                        
                        <span class="zoom-social_icons-list-span dashicons dashicons-rss" data-hover-rule="background-color" data-hover-color="#ff7f00" style="background-color : #ff7f00; font-size: 36px; padding:4px" ></span>

                                            </a>
                </li>

            
                                <li class="zoom-social_icons-list__item">
                    <a class="zoom-social_icons-list__link"
                       href="https://www.bloghouston.com/subscribe"  >
                                                                        
                                                    <span class="screen-reader-text">mail</span>
                        
                        <span class="zoom-social_icons-list-span socicon socicon-mail" data-hover-rule="background-color" data-hover-color="#69bf2b" style="background-color : #54a806; font-size: 36px; padding:4px" ></span>

                                            </a>
                </li>

            
        </ul>

        </div><div id="mh_magazine_custom_posts-5" class="mh-widget mh_magazine_custom_posts"><h4 class="mh-widget-title"><span class="mh-widget-title-inner">Latest Publications</span></h4>			<ul class="mh-custom-posts-widget mh-custom-posts-no-image clearfix"> 						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-11213 post type-post status-publish format-standard has-post-thumbnail category-commentary tag-coronavirus tag-covid-19 tag-galleria tag-hygiene tag-mask tag-neal-meyer tag-social-distance tag-westheimer">
														<div class="mh-custom-posts-header">
								<div class="mh-custom-posts-small-title">
									<a href="https://www.bloghouston.com/2020/05/the-2020-covid-19-coronavirus-saga-the-mid-may-edition/" title="The 2020 COVID-19 (coronavirus) saga: The mid-May edition">
										The 2020 COVID-19 (coronavirus) saga: The mid-May edition									</a>
								</div>
								<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://www.bloghouston.com/2020/05/">May 17, 2020</a></span>
</div>
							</div>
						</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-11202 post type-post status-publish format-standard has-post-thumbnail category-linkposts tag-city-of-houston tag-contact-tracing tag-covid-19 tag-dave-ward tag-diane-trautman tag-dr-joseph-varon tag-energy tag-greg-abbott tag-harris-county tag-houston-chronicle tag-josue-daniel-claros-trajedo tag-lina-hidalgo tag-robert-bradley-jr tag-rodney-ellis tag-united-methodist-medical-center">
														<div class="mh-custom-posts-header">
								<div class="mh-custom-posts-small-title">
									<a href="https://www.bloghouston.com/2020/05/weekend-brunch-for-10-may-2020/" title="Weekend brunch for 10 May 2020">
										Weekend brunch for 10 May 2020									</a>
								</div>
								<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://www.bloghouston.com/2020/05/">May 10, 2020</a></span>
</div>
							</div>
						</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-11192 post type-post status-publish format-standard has-post-thumbnail category-linkposts tag-art-acevedo tag-bias tag-covid-19 tag-elm-grove tag-gerald-goines tag-greg-abbott tag-harris-county tag-jason-knox tag-kinder-institute tag-lina-hidalgo tag-mike-knox tag-perry-homes tag-stay-home-houston-chronicle">
														<div class="mh-custom-posts-header">
								<div class="mh-custom-posts-small-title">
									<a href="https://www.bloghouston.com/2020/05/weekend-brunch-for-3-may-2020/" title="Weekend brunch for 3 May 2020">
										Weekend brunch for 3 May 2020									</a>
								</div>
								<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://www.bloghouston.com/2020/05/">May 3, 2020</a></span>
</div>
							</div>
						</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-11178 post type-post status-publish format-standard has-post-thumbnail category-linkposts tag-art-acevedo tag-budget tag-covid-19 tag-criminal-justice tag-garbage-fee tag-holly-hansen tag-houston-chronicle tag-lina-hidalgo tag-metro tag-miya-shay tag-post-oak-brt tag-sylvester-turner tag-transparency">
														<div class="mh-custom-posts-header">
								<div class="mh-custom-posts-small-title">
									<a href="https://www.bloghouston.com/2020/04/weekend-brunch-for-26-april-2020/" title="Weekend brunch for 26 April 2020">
										Weekend brunch for 26 April 2020									</a>
								</div>
								<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://www.bloghouston.com/2020/04/">April 26, 2020</a></span>
</div>
							</div>
						</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-11169 post type-post status-publish format-standard has-post-thumbnail category-linkposts tag-asiatown tag-china tag-covid-19 tag-crowdsource-rescue tag-density tag-economy tag-energy tag-houston-chronicle tag-spur-527 tag-urban-planning">
														<div class="mh-custom-posts-header">
								<div class="mh-custom-posts-small-title">
									<a href="https://www.bloghouston.com/2020/04/weekend-brunch-for-19-april-2020/" title="Weekend brunch for 19 April 2020">
										Weekend brunch for 19 April 2020									</a>
								</div>
								<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://www.bloghouston.com/2020/04/">April 19, 2020</a></span>
</div>
							</div>
						</li>			</ul></div>	</aside>	</div>
    </div>
<footer class="mh-footer" itemscope="itemscope" itemtype="https://schema.org/WPFooter">
<div class="mh-container mh-container-inner mh-footer-widgets mh-row clearfix">
<div class="mh-col-1-4 mh-widget-col-1 mh-footer-4-cols  mh-footer-area mh-footer-1">
<div id="custom_html-2" class="widget_text mh-footer-widget widget_custom_html"><div class="textwidget custom-html-widget"><br />
blogHOUSTON is an independent source for commentary on Houston-area politics, media, and culture.</div></div></div>
<div class="mh-col-1-4 mh-widget-col-1 mh-footer-4-cols  mh-footer-area mh-footer-2">
<div id="custom_html-3" class="widget_text mh-footer-widget widget_custom_html"><div class="textwidget custom-html-widget"></div></div></div>
<div class="mh-col-1-4 mh-widget-col-1 mh-footer-4-cols  mh-footer-area mh-footer-3">
<div id="custom_html-4" class="widget_text mh-footer-widget widget_custom_html"><div class="textwidget custom-html-widget"></div></div></div>
<div class="mh-col-1-4 mh-widget-col-1 mh-footer-4-cols  mh-footer-area mh-footer-4">
<div id="custom_html-5" class="widget_text mh-footer-widget widget_custom_html"><div class="textwidget custom-html-widget"><b>CONTACT INFORMATION</b><br />
blogHOUSTON<br />
PO Box 631424<br />
Houston, TX 77263<br />
<a href="mailto:blogHOUSTON+f@gmail.com"><u>blogHOUSTON@gmail.com</u></a></div></div></div>
</div>
</footer>
<div class="mh-copyright-wrap">
	<div class="mh-container mh-container-inner clearfix">
		<p class="mh-copyright">
			Copyright © 2004-2020, blogHOUSTON		</p>
	</div>
</div>
<a href="#" class="mh-back-to-top"><i class="fa fa-chevron-up"></i></a>
</div><!-- .mh-container-outer -->
        <script type="text/javascript">
        var vanilla_forum_url = 'https://www.bloghouston.com/forum';
        (function() {
            var vanilla_count = document.createElement('script');
            vanilla_count.type = 'text/javascript';
            vanilla_count.src = vanilla_forum_url + '/js/count.js';
            (document.getElementsByTagName('head')[0] || document.getElementsByTagName('body')[0]).appendChild(vanilla_count);
        })();
        </script>
    
<!-- WP Socializer 5.2.1 - JS - Start -->
<script>var wpsr_ajax_url = "https://www.bloghouston.com/wp-admin/admin-ajax.php";</script>
<!-- WP Socializer - JS - End -->
        <script type="text/javascript">
            (function(){
                document.addEventListener('DOMContentLoaded', function(){
                    let wpp_widgets = document.querySelectorAll('.popular-posts-sr');

                    if ( wpp_widgets ) {
                        for (let i = 0; i < wpp_widgets.length; i++) {
                            let wpp_widget = wpp_widgets[i];
                            WordPressPopularPosts.theme(wpp_widget);
                        }
                    }
                });
            })();
        </script>
                <script>
            var WPPImageObserver = null;

            function wpp_load_img(img) {
                if ( ! 'imgSrc' in img.dataset || ! img.dataset.imgSrc )
                    return;

                img.src = img.dataset.imgSrc;

                if ( 'imgSrcset' in img.dataset ) {
                    img.srcset = img.dataset.imgSrcset;
                    img.removeAttribute('data-img-srcset');
                }

                img.classList.remove('wpp-lazyload');
                img.removeAttribute('data-img-src');
                img.classList.add('wpp-lazyloaded');
            }

            function wpp_observe_imgs(){
                let wpp_images = document.querySelectorAll('img.wpp-lazyload'),
                    wpp_widgets = document.querySelectorAll('.popular-posts-sr');

                if ( wpp_images.length || wpp_widgets.length ) {
                    if ( 'IntersectionObserver' in window ) {
                        WPPImageObserver = new IntersectionObserver(function(entries, observer) {
                            entries.forEach(function(entry) {
                                if (entry.isIntersecting) {
                                    let img = entry.target;
                                    wpp_load_img(img);
                                    WPPImageObserver.unobserve(img);
                                }
                            });
                        });

                        if ( wpp_images.length ) {
                            wpp_images.forEach(function(image) {
                                WPPImageObserver.observe(image);
                            });
                        }

                        if ( wpp_widgets.length ) {
                            for (var i = 0; i < wpp_widgets.length; i++) {
                                let wpp_widget_images = wpp_widgets[i].querySelectorAll('img.wpp-lazyload');

                                if ( ! wpp_widget_images.length && wpp_widgets[i].shadowRoot ) {
                                    wpp_widget_images = wpp_widgets[i].shadowRoot.querySelectorAll('img.wpp-lazyload');
                                }

                                if ( wpp_widget_images.length ) {
                                    wpp_widget_images.forEach(function(image) {
                                        WPPImageObserver.observe(image);
                                    });
                                }
                            }
                        }
                    } /** Fallback for older browsers */
                    else {
                        if ( wpp_images.length ) {
                            for (var i = 0; i < wpp_images.length; i++) {
                                wpp_load_img(wpp_images[i]);
                                wpp_images[i].classList.remove('wpp-lazyloaded');
                            }
                        }

                        if ( wpp_widgets.length ) {
                            for (var j = 0; j < wpp_widgets.length; j++) {
                                let wpp_widget = wpp_widgets[j],
                                    wpp_widget_images = wpp_widget.querySelectorAll('img.wpp-lazyload');

                                if ( ! wpp_widget_images.length && wpp_widget.shadowRoot ) {
                                    wpp_widget_images = wpp_widget.shadowRoot.querySelectorAll('img.wpp-lazyload');
                                }

                                if ( wpp_widget_images.length ) {
                                    for (var k = 0; k < wpp_widget_images.length; k++) {
                                        wpp_load_img(wpp_widget_images[k]);
                                        wpp_widget_images[k].classList.remove('wpp-lazyloaded');
                                    }
                                }
                            }
                        }
                    }
                }
            }

            document.addEventListener('DOMContentLoaded', function() {
                wpp_observe_imgs();

                // When an ajaxified WPP widget loads,
                // Lazy load its images
                document.addEventListener('wpp-onload', function(){
                    wpp_observe_imgs();
                });
            });
        </script>
        <script type='text/javascript' src='https://www.bloghouston.com/wp-includes/js/jquery/ui/core.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://www.bloghouston.com/wp-content/plugins/stopbadbots/assets/js/stopbadbots_fingerprint.js'></script>
<script type='text/javascript' src='https://www.bloghouston.com/wp-content/plugins/stopbadbots/assets/js/stopbadbots.js'></script>
<script type='text/javascript' src='https://www.bloghouston.com/wp-includes/js/comment-reply.min.js?ver=53beb039abc5bc0ba0c55aafbecaca64'></script>
<script type='text/javascript' src='https://www.bloghouston.com/wp-content/plugins/social-icons-widget-by-wpzoom/assets/js/social-icons-widget-frontend.js?ver=1586739947'></script>
<script type='text/javascript' src='https://www.bloghouston.com/wp-includes/js/wp-embed.min.js?ver=53beb039abc5bc0ba0c55aafbecaca64'></script>
<script type='text/javascript' src='https://www.bloghouston.com/wp-content/plugins/wp-socializer/public/js/wp-socializer.min.js?ver=5.2.1'></script>
</body>
</html>