<!DOCTYPE html>
<html class="no-js mh-one-sb" lang="en-US">
<head>
<meta charset="UTF-8">
<meta name="viewport" content="width=device-width, initial-scale=1.0">
<link rel="profile" href="http://gmpg.org/xfn/11" />

	<!-- This site is optimized with the Yoast SEO plugin v14.4.1 - https://yoast.com/wordpress/plugins/seo/ -->
	<title>Weekend brunch for 5 July 2020 - blogHOUSTON</title>
	<meta name="description" content="HPD releases audit of narcotics department; Additional officers from that department are charged; COVID-19 cases continue to climb; and more!" />
	<meta name="robots" content="index, follow" />
	<meta name="googlebot" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" />
	<meta name="bingbot" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" />
	<link rel="canonical" href="https://www.bloghouston.com/2020/07/weekend-brunch-for-5-july-2020/" />
	<meta property="og:locale" content="en_US" />
	<meta property="og:type" content="article" />
	<meta property="og:title" content="Weekend brunch for 5 July 2020 - blogHOUSTON" />
	<meta property="og:description" content="HPD releases audit of narcotics department; Additional officers from that department are charged; COVID-19 cases continue to climb; and more!" />
	<meta property="og:url" content="https://www.bloghouston.com/2020/07/weekend-brunch-for-5-july-2020/" />
	<meta property="og:site_name" content="blogHOUSTON" />
	<meta property="article:publisher" content="https://www.facebook.com/blogHOUSTON" />
	<meta property="article:published_time" content="2020-07-06T03:00:36+00:00" />
	<meta property="article:modified_time" content="2020-07-06T15:29:32+00:00" />
	<meta property="og:image" content="https://www.bloghouston.com/wp-content/uploads/2019/06/popsicles_Marcho-Verch_flickr.jpg" />
	<meta property="og:image:width" content="640" />
	<meta property="og:image:height" content="427" />
	<meta name="twitter:card" content="summary" />
	<meta name="twitter:creator" content="@PubliusTX" />
	<meta name="twitter:site" content="@blogHOUSTON" />
	<script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"https://www.bloghouston.com/#organization","name":"blogHOUSTON","url":"https://www.bloghouston.com/","sameAs":["https://www.facebook.com/blogHOUSTON","https://www.linkedin.com/company/bloghouston","https://twitter.com/blogHOUSTON"],"logo":{"@type":"ImageObject","@id":"https://www.bloghouston.com/#logo","inLanguage":"en-US","url":"https://www.bloghouston.com/wp-content/uploads/blogHOUSTON_logo.png","width":249,"height":100,"caption":"blogHOUSTON"},"image":{"@id":"https://www.bloghouston.com/#logo"}},{"@type":"WebSite","@id":"https://www.bloghouston.com/#website","url":"https://www.bloghouston.com/","name":"blogHOUSTON","description":"Houston&#039;s conservative alternative since 2004","publisher":{"@id":"https://www.bloghouston.com/#organization"},"potentialAction":[{"@type":"SearchAction","target":"https://www.bloghouston.com/?s={search_term_string}","query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://www.bloghouston.com/2020/07/weekend-brunch-for-5-july-2020/#primaryimage","inLanguage":"en-US","url":"https://www.bloghouston.com/wp-content/uploads/2019/06/popsicles_Marcho-Verch_flickr.jpg","width":640,"height":427,"caption":"Image credit: Marcho Verch/flickr (CC BY 2.0)"},{"@type":"WebPage","@id":"https://www.bloghouston.com/2020/07/weekend-brunch-for-5-july-2020/#webpage","url":"https://www.bloghouston.com/2020/07/weekend-brunch-for-5-july-2020/","name":"Weekend brunch for 5 July 2020 - blogHOUSTON","isPartOf":{"@id":"https://www.bloghouston.com/#website"},"primaryImageOfPage":{"@id":"https://www.bloghouston.com/2020/07/weekend-brunch-for-5-july-2020/#primaryimage"},"datePublished":"2020-07-06T03:00:36+00:00","dateModified":"2020-07-06T15:29:32+00:00","description":"HPD releases audit of narcotics department; Additional officers from that department are charged; COVID-19 cases continue to climb; and more!","inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://www.bloghouston.com/2020/07/weekend-brunch-for-5-july-2020/"]}]},{"@type":"Article","@id":"https://www.bloghouston.com/2020/07/weekend-brunch-for-5-july-2020/#article","isPartOf":{"@id":"https://www.bloghouston.com/2020/07/weekend-brunch-for-5-july-2020/#webpage"},"author":{"@id":"https://www.bloghouston.com/#/schema/person/7d9205b935bac8070b0cc7dcd1779a01"},"headline":"Weekend brunch for 5 July 2020","datePublished":"2020-07-06T03:00:36+00:00","dateModified":"2020-07-06T15:29:32+00:00","commentCount":0,"mainEntityOfPage":{"@id":"https://www.bloghouston.com/2020/07/weekend-brunch-for-5-july-2020/#webpage"},"publisher":{"@id":"https://www.bloghouston.com/#organization"},"image":{"@id":"https://www.bloghouston.com/2020/07/weekend-brunch-for-5-july-2020/#primaryimage"},"keywords":"7815 Harding St Raid,Art Acevedo,COVID-19,Gerald Goines,Greg Abbott,Harding Street Massacre,Houston Fire Department,HPD,HPD Narcotics audit,Leticia Plummer,Lina Hidalgo,Sylvester Turner","articleSection":"Around The Web","inLanguage":"en-US","potentialAction":[{"@type":"CommentAction","name":"Comment","target":["https://www.bloghouston.com/2020/07/weekend-brunch-for-5-july-2020/#respond"]}]},{"@type":["Person"],"@id":"https://www.bloghouston.com/#/schema/person/7d9205b935bac8070b0cc7dcd1779a01","name":"Kevin Whited","image":{"@type":"ImageObject","@id":"https://www.bloghouston.com/#personlogo","inLanguage":"en-US","url":"https://www.bloghouston.com/wp-content/uploads/2020/01/WSJ-portrait_KW2019_frameless.png","caption":"Kevin Whited"},"description":"Kevin Whited is co-founder and publisher of blogHOUSTON. Follow him on twitter: @PubliusTX","sameAs":["https://twitter.com/PubliusTX"]}]}</script>
	<!-- / Yoast SEO plugin. -->


<link rel='dns-prefetch' href='//use.fontawesome.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="blogHOUSTON &raquo; Feed" href="https://www.bloghouston.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="blogHOUSTON &raquo; Comments Feed" href="https://www.bloghouston.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="blogHOUSTON &raquo; Weekend brunch for 5 July 2020 Comments Feed" href="https://www.bloghouston.com/2020/07/weekend-brunch-for-5-july-2020/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.bloghouston.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=9b6543cf57294487a3cc8e05eb1d1e8a"}};
			/*! This file is auto-generated */
			!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='dashicons-css'  href='https://www.bloghouston.com/wp-includes/css/dashicons.min.css?ver=9b6543cf57294487a3cc8e05eb1d1e8a' type='text/css' media='all' />
<link rel='stylesheet' id='wpzoom-social-icons-academicons-css'  href='https://www.bloghouston.com/wp-content/plugins/social-icons-widget-by-wpzoom/assets/css/academicons.min.css?ver=1586739947' type='text/css' media='all' />
<link rel='stylesheet' id='wpzoom-social-icons-socicon-css'  href='https://www.bloghouston.com/wp-content/plugins/social-icons-widget-by-wpzoom/assets/css/socicon.css?ver=1586739947' type='text/css' media='all' />
<link rel='stylesheet' id='wpzoom-social-icons-font-awesome-5-css'  href='https://www.bloghouston.com/wp-content/plugins/social-icons-widget-by-wpzoom/assets/css/font-awesome-5.min.css?ver=1586739947' type='text/css' media='all' />
<link rel='stylesheet' id='wpzoom-social-icons-genericons-css'  href='https://www.bloghouston.com/wp-content/plugins/social-icons-widget-by-wpzoom/assets/css/genericons.css?ver=1586739947' type='text/css' media='all' />
<link rel='stylesheet' id='wp-block-library-css'  href='https://www.bloghouston.com/wp-includes/css/dist/block-library/style.min.css?ver=9b6543cf57294487a3cc8e05eb1d1e8a' type='text/css' media='all' />
<link rel='stylesheet' id='wpzoom-social-icons-block-style-css'  href='https://www.bloghouston.com/wp-content/plugins/social-icons-widget-by-wpzoom/block/dist/blocks.style.build.css?ver=1586739947' type='text/css' media='all' />
<link rel='stylesheet' id='wpsr_main_css-css'  href='https://www.bloghouston.com/wp-content/plugins/wp-socializer/public/css/wpsr.min.css?ver=5.2.1' type='text/css' media='all' />
<link rel='stylesheet' id='wpsr_sb_icon_css-css'  href='https://use.fontawesome.com/releases/v5.12.0/css/all.css?ver=5.2.1' type='text/css' media='all' />
<link rel='stylesheet' id='wordpress-popular-posts-css-css'  href='https://www.bloghouston.com/wp-content/plugins/wordpress-popular-posts/assets/css/wpp.css?ver=5.1.0' type='text/css' media='all' />
<link rel='stylesheet' id='mh-magazine-css'  href='https://www.bloghouston.com/wp-content/themes/mh-magazine/style.css?ver=3.9.5' type='text/css' media='all' />
<link rel='stylesheet' id='mh-font-awesome-css'  href='https://www.bloghouston.com/wp-content/themes/mh-magazine/includes/font-awesome.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='mh-google-fonts-css'  href='https://fonts.googleapis.com/css?family=Open+Sans:300,400,400italic,600,700' type='text/css' media='all' />
<link rel='stylesheet' id='wpzoom-social-icons-font-awesome-3-css'  href='https://www.bloghouston.com/wp-content/plugins/social-icons-widget-by-wpzoom/assets/css/font-awesome-3.min.css?ver=1586739947' type='text/css' media='all' />
<script type='text/javascript' src='https://www.bloghouston.com/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp'></script>
<script type='text/javascript' src='https://www.bloghouston.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var wpp_params = {"sampling_active":"0","sampling_rate":"100","ajax_url":"https:\/\/www.bloghouston.com\/wp-json\/wordpress-popular-posts\/v1\/popular-posts","ID":"11322","token":"bc0d07959c","debug":""};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.bloghouston.com/wp-content/plugins/wordpress-popular-posts/assets/js/wpp-5.0.0.min.js?ver=5.1.0'></script>
<script type='text/javascript' src='https://www.bloghouston.com/wp-content/themes/mh-magazine/js/scripts.js?ver=3.9.5'></script>
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.bloghouston.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.bloghouston.com/wp-includes/wlwmanifest.xml" /> 

<link rel='shortlink' href='https://www.bloghouston.com/?p=11322' />
<link rel="alternate" type="application/json+oembed" href="https://www.bloghouston.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.bloghouston.com%2F2020%2F07%2Fweekend-brunch-for-5-july-2020%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.bloghouston.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.bloghouston.com%2F2020%2F07%2Fweekend-brunch-for-5-july-2020%2F&#038;format=xml" />
<script type="text/javascript">
           var ajaxurl = "https://www.bloghouston.com/wp-admin/admin-ajax.php";
         </script><!-- This code is added by WP Analytify (3.0.0) https://analytify.io/downloads/analytify-wordpress-plugin/ !-->				 <script>
				 (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
					 (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
					 m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
				 })

				 (window,document,'script','//www.google-analytics.com/analytics.js','ga');
				 	ga('create', 'UA-135422-3', 'auto');ga('send', 'pageview');				 </script>

				 <!-- This code is added by WP Analytify (3.0.0) !--><style type="text/css">
.mh-navigation li:hover, .mh-navigation ul li:hover > ul, .mh-main-nav-wrap, .mh-main-nav, .mh-social-nav li a:hover, .entry-tags li, .mh-slider-caption, .mh-widget-layout8 .mh-widget-title .mh-footer-widget-title-inner, .mh-widget-col-1 .mh-slider-caption, .mh-widget-col-1 .mh-posts-lineup-caption, .mh-carousel-layout1, .mh-spotlight-widget, .mh-social-widget li a, .mh-author-bio-widget, .mh-footer-widget .mh-tab-comment-excerpt, .mh-nip-item:hover .mh-nip-overlay, .mh-widget .tagcloud a, .mh-footer-widget .tagcloud a, .mh-footer, .mh-copyright-wrap, input[type=submit]:hover, #infinite-handle span:hover { background: #5e5e5e; }
.mh-extra-nav-bg { background: rgba(94, 94, 94, 0.2); }
.mh-slider-caption, .mh-posts-stacked-title, .mh-posts-lineup-caption { background: #5e5e5e; background: rgba(94, 94, 94, 0.8); }
@media screen and (max-width: 900px) { #mh-mobile .mh-slider-caption, #mh-mobile .mh-posts-lineup-caption { background: rgba(94, 94, 94, 1); } }
.slicknav_menu, .slicknav_nav ul, #mh-mobile .mh-footer-widget .mh-posts-stacked-overlay { border-color: #5e5e5e; }
.mh-copyright, .mh-copyright a { color: #fff; }
.mh-widget-layout4 .mh-widget-title { background: #0071bc; background: rgba(0, 113, 188, 0.6); }
.mh-preheader, .mh-wide-layout .mh-subheader, .mh-ticker-title, .mh-main-nav li:hover, .mh-footer-nav, .slicknav_menu, .slicknav_btn, .slicknav_nav .slicknav_item:hover, .slicknav_nav a:hover, .mh-back-to-top, .mh-subheading, .entry-tags .fa, .entry-tags li:hover, .mh-widget-layout2 .mh-widget-title, .mh-widget-layout4 .mh-widget-title-inner, .mh-widget-layout4 .mh-footer-widget-title, .mh-widget-layout5 .mh-widget-title-inner, .mh-widget-layout6 .mh-widget-title, #mh-mobile .flex-control-paging li a.flex-active, .mh-image-caption, .mh-carousel-layout1 .mh-carousel-caption, .mh-tab-button.active, .mh-tab-button.active:hover, .mh-footer-widget .mh-tab-button.active, .mh-social-widget li:hover a, .mh-footer-widget .mh-social-widget li a, .mh-footer-widget .mh-author-bio-widget, .tagcloud a:hover, .mh-widget .tagcloud a:hover, .mh-footer-widget .tagcloud a:hover, .mh-posts-stacked-item .mh-meta, .page-numbers:hover, .mh-loop-pagination .current, .mh-comments-pagination .current, .pagelink, a:hover .pagelink, input[type=submit], #infinite-handle span { background: #0071bc; }
.mh-main-nav-wrap .slicknav_nav ul, blockquote, .mh-widget-layout1 .mh-widget-title, .mh-widget-layout3 .mh-widget-title, .mh-widget-layout5 .mh-widget-title, .mh-widget-layout8 .mh-widget-title:after, #mh-mobile .mh-slider-caption, .mh-carousel-layout1, .mh-spotlight-widget, .mh-author-bio-widget, .mh-author-bio-title, .mh-author-bio-image-frame, .mh-video-widget, .mh-tab-buttons, textarea:hover, input[type=text]:hover, input[type=email]:hover, input[type=tel]:hover, input[type=url]:hover { border-color: #0071bc; }
.mh-header-tagline, .mh-dropcap, .mh-carousel-layout1 .flex-direction-nav a, .mh-carousel-layout2 .mh-carousel-caption, .mh-posts-digest-small-category, .mh-posts-lineup-more, .bypostauthor .fn:after, .mh-comment-list .comment-reply-link:before, #respond #cancel-comment-reply-link:before { color: #0071bc; }
.mh-subheader, .page-numbers, a .pagelink, .mh-widget-layout3 .mh-widget-title, .mh-widget .search-form, .mh-tab-button, .mh-tab-content, .mh-nip-widget, .mh-magazine-facebook-page-widget, .mh-social-widget, .mh-posts-horizontal-widget, .mh-ad-spot, .mh-info-spot { background: #b3b3b3; }
.mh-tab-post-item { border-color: rgba(255, 255, 255, 0.3); }
.mh-tab-comment-excerpt { background: rgba(255, 255, 255, 0.6); }
.entry-content a { color: #0071bc; }
a:hover, .entry-content a:hover, #respond a:hover, #respond #cancel-comment-reply-link:hover, #respond .logged-in-as a:hover, .mh-comment-list .comment-meta a:hover, .mh-ping-list .mh-ping-item a:hover, .mh-meta a:hover, .mh-breadcrumb a:hover, .mh-tabbed-widget a:hover { color: #0071bc; }
</style>
<!--[if lt IE 9]>
<script src="https://www.bloghouston.com/wp-content/themes/mh-magazine/js/css3-mediaqueries.js"></script>
<![endif]-->
<link rel="icon" href="https://www.bloghouston.com/wp-content/uploads/cropped-favicon_bh2019-1-32x32.png" sizes="32x32" />
<link rel="icon" href="https://www.bloghouston.com/wp-content/uploads/cropped-favicon_bh2019-1-192x192.png" sizes="192x192" />
<link rel="apple-touch-icon" href="https://www.bloghouston.com/wp-content/uploads/cropped-favicon_bh2019-1-180x180.png" />
<meta name="msapplication-TileImage" content="https://www.bloghouston.com/wp-content/uploads/cropped-favicon_bh2019-1-270x270.png" />
		<style type="text/css" id="wp-custom-css">
			#col1 ul, #col2 ul, #col3 ul {margin-left: 12px; padding-left: 6px; padding-right: 18px}
#col1 li, #col2 li, #col3 li {font-size: 12px; line-height: 130%; margin-bottom: 8px}
#col1 h3 {padding-top:15px}
#col2 h3 {padding-top:15px}
#col3 h3 {padding-top:15px}
#better_rss_widget-12 li {font-weight: 700; padding: 5px 0; border-bottom: 1px dotted #ebebeb; }
.wpp-list li {font-weight: 700; padding: 5px 0; border-bottom: 1px dotted #ebebeb; }
#linkcat-8 li {font-weight: 700; padding: 5px 0; border-bottom: 1px dotted #ebebeb; }
.zoom-social-icons-widget {padding-bottom: 18px;border-bottom: 1px dotted #ebebeb;}

#vf-widget-discussions li {font-weight: 700; padding: 5px 0; border-bottom: 1px dotted #ebebeb; }
blockquote {font-style:normal; font-size: 14px; font-size: 0.850rem; line-height: 1.5; margin-left: 25px}		</style>
		</head>
<body id="mh-mobile" class="post-template-default single single-post postid-11322 single-format-standard wp-custom-logo mh-boxed-layout mh-right-sb mh-loop-layout1 mh-widget-layout5" itemscope="itemscope" itemtype="https://schema.org/WebPage">
<div class="mh-container mh-container-outer">
<div class="mh-header-nav-mobile clearfix"></div>
	<div class="mh-preheader">
    	<div class="mh-container mh-container-inner mh-row clearfix">
							<div class="mh-header-bar-content mh-header-bar-top-left mh-col-2-3 clearfix">
									</div>
								</div>
	</div>
<header class="mh-header" itemscope="itemscope" itemtype="https://schema.org/WPHeader">
	<div class="mh-container mh-container-inner clearfix">
		<div class="mh-custom-header clearfix">
<div class="mh-header-columns mh-row clearfix">
<div class="mh-col-1-1 mh-site-identity">
<div class="mh-site-logo" role="banner" itemscope="itemscope" itemtype="https://schema.org/Brand">
<a href="https://www.bloghouston.com/" class="custom-logo-link" rel="home"><img width="249" height="100" src="https://www.bloghouston.com/wp-content/uploads/blogHOUSTON_logo.png" class="custom-logo" alt="blogHOUSTON logo" /></a></div>
</div>
</div>
</div>
	</div>
	<div class="mh-main-nav-wrap">
		<nav class="mh-navigation mh-main-nav mh-container mh-container-inner clearfix" itemscope="itemscope" itemtype="https://schema.org/SiteNavigationElement">
			<div class="menu-main-container"><ul id="menu-main" class="menu"><li id="menu-item-75" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-75"><a href="https://www.bloghouston.com">Front Page</a></li>
<li id="menu-item-83" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-83"><a title="Articles published by blogHOUSTON">Sections</a>
<ul class="sub-menu">
	<li id="menu-item-9253" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-9253"><a href="https://www.bloghouston.com/section/linkposts/">Around The Web</a></li>
	<li id="menu-item-9250" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-9250"><a href="https://www.bloghouston.com/section/articles/commentary/">Commentary</a></li>
	<li id="menu-item-9251" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-9251"><a href="https://www.bloghouston.com/section/articles/guest-commentary/">Guest Commentary</a></li>
	<li id="menu-item-9256" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-9256"><a href="https://www.bloghouston.com/section/brief/">In Brief</a></li>
	<li id="menu-item-9254" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-9254"><a href="https://www.bloghouston.com/section/news-releases/">News Releases</a></li>
</ul>
</li>
<li id="menu-item-6695" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-6695"><a title="Chronological archives of articles on blogHOUSTON" href="https://www.bloghouston.com/archives/">Archives</a></li>
<li id="menu-item-9432" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-9432"><a href="https://www.bloghouston.com/discussions/">Forum</a></li>
<li id="menu-item-71" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-71"><a href="https://www.bloghouston.com/about/">About</a></li>
<li id="menu-item-70" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-70"><a href="https://www.bloghouston.com/headlines/">Headlines</a></li>
</ul></div>		</nav>
	</div>
	</header>
	<div class="mh-subheader">
		<div class="mh-container mh-container-inner mh-row clearfix">
										<div class="mh-header-bar-content mh-header-bar-bottom-right mh-col-1-3 clearfix">
											<aside class="mh-header-search mh-header-search-bottom">
							<form role="search" method="get" class="search-form" action="https://www.bloghouston.com/">
				<label>
					<span class="screen-reader-text">Search for:</span>
					<input type="search" class="search-field" placeholder="Search &hellip;" value="" name="s" />
				</label>
				<input type="submit" class="search-submit" value="Search" />
			</form>						</aside>
									</div>
					</div>
	</div>
<div class="mh-wrapper clearfix">
	<div class="mh-main clearfix">
		<div id="main-content" class="mh-content" role="main" itemprop="mainContentOfPage"><nav class="mh-breadcrumb" itemscope itemtype="http://schema.org/BreadcrumbList"><span itemprop="itemListElement" itemscope itemtype="http://schema.org/ListItem"><a href="https://www.bloghouston.com" itemprop="item"><span itemprop="name">Home</span></a><meta itemprop="position" content="1" /></span><span class="mh-breadcrumb-delimiter"><i class="fa fa-angle-right"></i></span><span itemprop="itemListElement" itemscope itemtype="http://schema.org/ListItem"><a href="https://www.bloghouston.com/section/linkposts/" itemprop="item"><span itemprop="name">Around The Web</span></a><meta itemprop="position" content="2" /></span><span class="mh-breadcrumb-delimiter"><i class="fa fa-angle-right"></i></span>Weekend brunch for 5 July 2020</nav>
<article id="post-11322" class="post-11322 post type-post status-publish format-standard has-post-thumbnail hentry category-linkposts tag-7815-harding-st-raid tag-art-acevedo tag-covid-19 tag-gerald-goines tag-greg-abbott tag-harding-street-massacre tag-houston-fire-department tag-hpd tag-hpd-narcotics-audit tag-leticia-plummer tag-lina-hidalgo tag-sylvester-turner">
	<header class="entry-header clearfix"><h1 class="entry-title">Weekend brunch for 5 July 2020</h1><div class="mh-subheading-top"></div>
<h2 class="mh-subheading">News and views from around the web</h2>
<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://www.bloghouston.com/2020/07/">July 5, 2020</a></span>
<span class="entry-meta-author author vcard"><i class="fa fa-user"></i><a class="fn" href="https://www.bloghouston.com/author/kevin/">Kevin Whited</a></span>
<span class="entry-meta-categories"><i class="fa fa-folder-open-o"></i><a href="https://www.bloghouston.com/section/linkposts/" rel="category tag">Around The Web</a></span>
</div>
	</header>
		<div class="entry-content clearfix">
<figure class="entry-thumbnail">
<img src="https://www.bloghouston.com/wp-content/uploads/2019/06/popsicles_Marcho-Verch_flickr-640x381.jpg" alt="" title="tri colors popsicles" />
<figcaption class="wp-caption-text">Image credit: <a href="https://www.flickr.com/photos/30478819@N08/35519703302">Marcho Verch/flickr</a> (<a href="https://creativecommons.org/licenses/by/2.0/">CC BY 2.0</a>)</figcaption>
</figure>
<p><strong>[WB1]</strong> After an extended period of resisting media and other requests to release the internal <a href="https://www.scribd.com/document/467691769/2019-Houston-Police-Department-Narcotics-Division-Operational-Review">audit of HPD’s embattled narcotics department</a> after the Harding Street Massacre, Chief Art Acevedo <a href="https://www.houstonchronicle.com/news/houston-texas/houston/article/HPD-narcotics-audit-shows-sloppiness-lack-of-15381193.php">unexpectedly announced that it had been released this week</a> (conveniently, just before the big holiday weekend).</p>
<p><strong>[WB2]</strong> The Harris County DA’s office <a href="https://www.houstonchronicle.com/news/houston-texas/houston/article/Charges-against-Goines-and-members-of-his-Houston-15385335.php">also announced charges against additional narcotics officers who worked with former officer Gerald Goines</a>, the ringleader behind the Harding Street Massacre.</p>
<p><strong>[WB3]</strong> Meanwhile, COVID-19 cases and hospitalizations continued a climb in the Houston/Harris County area, and the <em>Chron</em>’s sensational coverage of the problem continues to result in basic errors being reported as fact, <a href="https://www.houstonchronicle.com/news/houston-texas/houston/article/texas-covid-19-response-greg-abbott-reopen-virus-15384725.php">such as the following</a>:</p>
<blockquote><p>And testing continued to lag far behind Abbott’s goal of 30,000 daily viral tests, averaging fewer than 20,000 for the first half of May</p></blockquote>
<p>Actually, if you pull the data from the <a href="https://txdshs.maps.arcgis.com/apps/opsdashboard/index.html#/ed483ecd702b4298ab01e8b9cafc8b83">Texas DSHS website</a> and do some simple calculations in Excel, you quickly discover that the state was exceeding 20,000 tests per day for the first half of May (when the <em>Chron</em> was also hysterically reporting “spikes” in positives that did not exist at the time).</p>
<figure id="attachment_11328" aria-describedby="caption-attachment-11328" style="width: 678px" class="wp-caption aligncenter"><img class="wp-image-11328 size-full" src="https://www.bloghouston.com/wp-content/uploads/2020/07/Testing-FirstHalfMay2020_TX.png" alt="" width="678" height="319" srcset="https://www.bloghouston.com/wp-content/uploads/2020/07/Testing-FirstHalfMay2020_TX.png 678w, https://www.bloghouston.com/wp-content/uploads/2020/07/Testing-FirstHalfMay2020_TX-300x141.png 300w" sizes="(max-width: 678px) 100vw, 678px" /><figcaption id="caption-attachment-11328" class="wp-caption-text">Daily COVID-19 tests in Texas, early May 2020 (source: Texas DSHS)</figcaption></figure>
<p>It&#8217;s still short of 30,000 tests per day, but it&#8217;s not under 20,000 tests per day. And for July 3 and July 4, Texas reported over 50,000 tests per day.</p>
<p>Many political leaders, public health “experts,” and media outlets continue to <a href="https://www.wsj.com/articles/the-coronavirus-credibility-gap-11593645643?mod=MorningEditorialReport&amp;mod=djemMER_h">squander their credibility</a> on almost a daily basis. We’ve noted before that too many journalists aren’t great with numbers, but even so, averages should not be THAT hard to get right. (<em>Note: To be generous, the story reference was to &#8220;viral&#8221; tests, but the distinction in test reporting came later, so this retrospective reporting almost seems designed to purposely exaggerate, when the larger point &#8212; fewer tests than the governor&#8217;s original stated goal &#8212; could have been made more cleanly)</em></p>
<p><strong>[WB4]</strong> There’s also this story in which a <em>Chron</em> reporter <a href="https://www.houstonchronicle.com/news/houston-texas/houston/article/hospitals-coronavirus-surge-tmc-cases-icu-capacity-15386006.php">managed to embed in a hospital to watch the goings on</a> (that certainly couldn’t have been that helpful to the beleaguered medical professionals trying to save people – although perhaps not as bad as when the newspaper had a <a href="https://www.bloghouston.com/2005/09/yes-the-chronicle-can-still-surprise-us/">reporter impersonate a Katrina refugee at a shelter</a>). Here is the young reporter’s assessment of the cause of the increase in hospital load:</p>
<blockquote><p>Models predict the disease will peak in mid-to-late July, almost two months after cases began to surge with the reopening of the Texas economy and a busy Memorial Day weekend.</p></blockquote>
<p>There is, inexplicably, no mention of the George Floyd demonstrations in Houston, which began on May 29 and built into the 60,000-strong march in June, or the endorsement of so many local leaders of these massive gatherings during a pandemic.</p>
<p>How big a role did those play in this increase? <a href="https://www.commentarymagazine.com/noah-rothman/the-protests-and-the-surge/">Almost certainly some</a>, even if it was just to signal that everything is fine and everyone should go on about their business (exactly the wrong signals to send during a pandemic).</p>
<p><strong>[WB5]</strong> Harris County Judge Lina Hidalgo has <a href="https://abc13.com/health/harris-county-bans-gatherings-of-10-or-more-people/6297783/">banned gatherings of 10 or more people (with some exceptions) through August</a>, and Mayor Turner (who encouraged the Floyd protests and whose police chief participated without a mask much of the time) urged Gov. Greg Abbott to <a href="https://www.khou.com/article/news/health/coronavirus/mayor-turner-says-houston-has-small-window-to-slow-covid-19-trajectory-to-avoid-last-resort/285-c1701482-ca50-4855-8f12-64626e76906a">give him more power to order citizens around</a>. Meanwhile, thousands <a href="https://www.houstonchronicle.com/news/houston-texas/houston/article/Protesters-demand-justice-for-Vanessa-Guillen-at-15386606.php">marched downtown this weekend</a>, with no apparent discouragement from anyone.</p>
<p>Local leaders have squandered their credibility, so it’s hard to blame citizens for <a href="https://reason.com/2020/07/03/post-pandemic-americans-may-be-done-with-taking-orders/">tuning them out</a>. We are largely going to have to figure this out on our own.</p>
<p><strong>[WB6]</strong> Unconcerned Texas GOP leaders decided their in-person convention in Houston that is scheduled to begin on 16 July <a href="https://www.texastribune.org/2020/07/02/texas-republicans-coronavirus-convention/">will go on as planned</a>. What could possibly go wrong?</p>
<p><strong>[WB7]</strong> The Houston Fire Department is <a href="https://abc13.com/houston-fire-department-firefighter-shortage-coronavirus-quarantine-covid-19/6295923/">very much in a bind</a>, with staffing numbers that were already declining as a result of Mayor Sylvester Turner’s policies and now with a record number of firefighters in quarantine.</p>
<p><strong>[WB8]</strong> City Council this past week <a href="https://www.houstonchronicle.com/news/houston-texas/houston/article/Council-members-want-City-Hall-credentials-of-15380476.php">revoked the City Hall credentials of Councilmember Leticia Plummer’s brother after his recent bad behavior</a>. Plummer’s recent grandstanding has resulted in her nearly complete alienation from other councilmembers, who also showed their displeasure by refusing even to second her motions during the recent budget debate.</p>
<p>Never miss a blogHOUSTON update – be sure to <a href="https://www.bloghouston.com/subscribe/">sign up for email alerts</a>.</p>
<div class="wp-socializer wpsr-buttons "><div class="wpsr-btn"><div class="socializer sr-popup sr-32px sr-opacity sr-pad"><span class="sr-facebook"><a rel="nofollow" href="https://www.facebook.com/share.php?u=https://www.bloghouston.com/2020/07/weekend-brunch-for-5-july-2020/" target="_blank"  title="Share this on Facebook"  style="color: #ffffff"><i class="fab fa-facebook-f"></i></a></span>
<span class="sr-twitter"><a rel="nofollow" href="https://twitter.com/intent/tweet?text=Weekend+brunch+for+5+July+2020%20-%20https://www.bloghouston.com/2020/07/weekend-brunch-for-5-july-2020/%20" target="_blank"  title="Tweet this !"  style="color: #ffffff"><i class="fab fa-twitter"></i></a></span>
<span class="sr-linkedin"><a rel="nofollow" href="https://www.linkedin.com/sharing/share-offsite/?url=https://www.bloghouston.com/2020/07/weekend-brunch-for-5-july-2020/" target="_blank"  title="Add this to LinkedIn"  style="color: #ffffff"><i class="fab fa-linkedin-in"></i></a></span>
<span class="sr-reddit"><a rel="nofollow" href="https://reddit.com/submit?url=https://www.bloghouston.com/2020/07/weekend-brunch-for-5-july-2020/&amp;title=Weekend+brunch+for+5+July+2020" target="_blank"  title="Submit this to Reddit"  style="color: #ffffff"><i class="fab fa-reddit-alien"></i></a></span>
<span class="sr-email"><a rel="nofollow" href="mailto:?to=&amp;subject=Weekend brunch for 5 July 2020&amp;body=HPD releases audit of narcotics department; Additional officers from that department are charged; CO%20-%20https://www.bloghouston.com/2020/07/weekend-brunch-for-5-july-2020/" target="_blank"  title="Email this "  style="color: #ffffff"><i class="fa fa-envelope"></i></a></span>
<span class="sr-print"><a rel="nofollow" href="https://www.printfriendly.com/print?url=https://www.bloghouston.com/2020/07/weekend-brunch-for-5-july-2020/" target="_blank"  title="Print this article "  style="color: #ffffff"><i class="fa fa-print"></i></a></span>
<span class="sr-pdf"><a rel="nofollow" href="https://www.printfriendly.com/print?url=https://www.bloghouston.com/2020/07/weekend-brunch-for-5-july-2020/" target="_blank"  title="Convert to PDF"  style="color: #ffffff"><i class="fa fa-file-pdf"></i></a></span></div></div></div>	</div></article><div class="mh-author-box clearfix">
	<figure class="mh-author-box-avatar">
		<img src="https://www.bloghouston.com/wp-content/uploads/2020/01/WSJ-portrait_KW2019_frameless-125x125.png" width="125" height="125" alt="Kevin Whited" class="avatar avatar-125 wp-user-avatar wp-user-avatar-125 alignnone photo" />	</figure>
	<div class="mh-author-box-header">
		<span class="mh-author-box-name">
			About Kevin Whited		</span>
					<span class="mh-author-box-postcount">
				<a href="https://www.bloghouston.com/author/kevin/" title="More articles written by Kevin Whited'">
					4237 Articles				</a>
			</span>
			</div>
			<div class="mh-author-box-bio">
			Kevin Whited is co-founder and publisher of blogHOUSTON. Follow him on twitter: <a href="http://www.twitter.com/PubliusTX">@PubliusTX</a>		</div>
				<div class="mh-author-box-contact">
																					<a class="mh-author-box-twitter" href="http://PubliusTX" title="Follow Kevin Whited on Twitter" target="_blank">
						<i class="fa fa-twitter"></i>
						<span class="screen-reader-text">Twitter</span>
					</a>
																			</div></div><nav class="mh-post-nav mh-row clearfix" itemscope="itemscope" itemtype="https://schema.org/SiteNavigationElement">
<div class="mh-col-1-2 mh-post-nav-item mh-post-nav-prev">
<a href="https://www.bloghouston.com/2020/06/weekend-brunch-for-28-june-2020/" rel="prev"><img width="80" height="60" src="https://www.bloghouston.com/wp-content/uploads/2020/06/UncleSam_2020_mask_20200628-80x60.jpg" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image" alt="" srcset="https://www.bloghouston.com/wp-content/uploads/2020/06/UncleSam_2020_mask_20200628-80x60.jpg 80w, https://www.bloghouston.com/wp-content/uploads/2020/06/UncleSam_2020_mask_20200628-326x245.jpg 326w" sizes="(max-width: 80px) 100vw, 80px" /><span>Previous</span><p>Weekend brunch for 28 June 2020</p></a></div>
</nav>
<section class="mh-related-content">
<h3 class="mh-widget-title mh-related-content-title">
<span class="mh-widget-title-inner">Related Articles</span></h3>
<div class="mh-related-wrap mh-row clearfix">
<div class="mh-col-1-3 mh-posts-grid-col clearfix">
<article class="post-9102 format-standard mh-posts-grid-item clearfix">
	<figure class="mh-posts-grid-thumb">
		<a class="mh-thumb-icon mh-thumb-icon-small-mobile" href="https://www.bloghouston.com/2018/07/calling-the-houston-fire-department-for-a-medical-emergency-is-hazardous-to-your-financial-health/" title="Calling the Houston Fire Department for a medical emergency is hazardous to your (financial) health"><img width="326" height="245" src="https://www.bloghouston.com/wp-content/uploads/HFD_pixabay-326x245.png" class="attachment-mh-magazine-medium size-mh-magazine-medium wp-post-image" alt="" srcset="https://www.bloghouston.com/wp-content/uploads/HFD_pixabay-326x245.png 326w, https://www.bloghouston.com/wp-content/uploads/HFD_pixabay-678x509.png 678w, https://www.bloghouston.com/wp-content/uploads/HFD_pixabay-80x60.png 80w" sizes="(max-width: 326px) 100vw, 326px" />		</a>
					<div class="mh-image-caption mh-posts-grid-caption">
				Commentary			</div>
			</figure>
	<h3 class="entry-title mh-posts-grid-title">
		<a href="https://www.bloghouston.com/2018/07/calling-the-houston-fire-department-for-a-medical-emergency-is-hazardous-to-your-financial-health/" title="Calling the Houston Fire Department for a medical emergency is hazardous to your (financial) health" rel="bookmark">
			Calling the Houston Fire Department for a medical emergency is hazardous to your (financial) health		</a>
	</h3>
	<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://www.bloghouston.com/2018/07/">July 12, 2018</a></span>
<span class="entry-meta-author author vcard"><i class="fa fa-user"></i><a class="fn" href="https://www.bloghouston.com/author/neal/">Neal Meyer</a></span>
<span class="entry-meta-categories"><i class="fa fa-folder-open-o"></i><a href="https://www.bloghouston.com/section/articles/commentary/" rel="category tag">Commentary</a></span>
</div>
	<div class="mh-posts-grid-excerpt clearfix">
		<div class="mh-excerpt"><p>Neal Meyer explains that calling an ambulance has become a very expensive proposition in Houston. <a class="mh-excerpt-more" href="https://www.bloghouston.com/2018/07/calling-the-houston-fire-department-for-a-medical-emergency-is-hazardous-to-your-financial-health/" title="Calling the Houston Fire Department for a medical emergency is hazardous to your (financial) health"></a></p>
</div>	</div>
</article></div>
<div class="mh-col-1-3 mh-posts-grid-col clearfix">
<article class="post-11103 format-standard mh-posts-grid-item clearfix">
	<figure class="mh-posts-grid-thumb">
		<a class="mh-thumb-icon mh-thumb-icon-small-mobile" href="https://www.bloghouston.com/2020/03/weekend-brunch-for-29-march-2020/" title="Weekend brunch for 29 March 2020"><img width="326" height="245" src="https://www.bloghouston.com/wp-content/uploads/2020/03/corona-4971013_640_Alexandra_Koch_Pixabay-326x245.jpg" class="attachment-mh-magazine-medium size-mh-magazine-medium wp-post-image" alt="" srcset="https://www.bloghouston.com/wp-content/uploads/2020/03/corona-4971013_640_Alexandra_Koch_Pixabay-326x245.jpg 326w, https://www.bloghouston.com/wp-content/uploads/2020/03/corona-4971013_640_Alexandra_Koch_Pixabay-80x60.jpg 80w" sizes="(max-width: 326px) 100vw, 326px" />		</a>
					<div class="mh-image-caption mh-posts-grid-caption">
				Around The Web			</div>
			</figure>
	<h3 class="entry-title mh-posts-grid-title">
		<a href="https://www.bloghouston.com/2020/03/weekend-brunch-for-29-march-2020/" title="Weekend brunch for 29 March 2020" rel="bookmark">
			Weekend brunch for 29 March 2020		</a>
	</h3>
	<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://www.bloghouston.com/2020/03/">March 29, 2020</a></span>
<span class="entry-meta-author author vcard"><i class="fa fa-user"></i><a class="fn" href="https://www.bloghouston.com/author/kevin/">Kevin Whited</a></span>
<span class="entry-meta-categories"><i class="fa fa-folder-open-o"></i><a href="https://www.bloghouston.com/section/linkposts/" rel="category tag">Around The Web</a></span>
</div>
	<div class="mh-posts-grid-excerpt clearfix">
		<div class="mh-excerpt"><p>The county goes on lockdown (with quite a few exceptions); Abbott preempts release of prisoners in Harris County; Tilman Fertitta plans to make it through; HEB plans to provision us; and more! <a class="mh-excerpt-more" href="https://www.bloghouston.com/2020/03/weekend-brunch-for-29-march-2020/" title="Weekend brunch for 29 March 2020"></a></p>
</div>	</div>
</article></div>
<div class="mh-col-1-3 mh-posts-grid-col clearfix">
<article class="post-9865 format-standard mh-posts-grid-item clearfix">
	<figure class="mh-posts-grid-thumb">
		<a class="mh-thumb-icon mh-thumb-icon-small-mobile" href="https://www.bloghouston.com/2019/02/weekend-brunch-for-3-february-2019/" title="Weekend brunch for 3 February 2019"><img width="326" height="245" src="https://www.bloghouston.com/wp-content/uploads/2019/02/working-breakfast_etee_flickr_cc20-326x245.jpg" class="attachment-mh-magazine-medium size-mh-magazine-medium wp-post-image" alt="" srcset="https://www.bloghouston.com/wp-content/uploads/2019/02/working-breakfast_etee_flickr_cc20-326x245.jpg 326w, https://www.bloghouston.com/wp-content/uploads/2019/02/working-breakfast_etee_flickr_cc20-300x225.jpg 300w, https://www.bloghouston.com/wp-content/uploads/2019/02/working-breakfast_etee_flickr_cc20-80x60.jpg 80w, https://www.bloghouston.com/wp-content/uploads/2019/02/working-breakfast_etee_flickr_cc20.jpg 640w" sizes="(max-width: 326px) 100vw, 326px" />		</a>
					<div class="mh-image-caption mh-posts-grid-caption">
				Around The Web			</div>
			</figure>
	<h3 class="entry-title mh-posts-grid-title">
		<a href="https://www.bloghouston.com/2019/02/weekend-brunch-for-3-february-2019/" title="Weekend brunch for 3 February 2019" rel="bookmark">
			Weekend brunch for 3 February 2019		</a>
	</h3>
	<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://www.bloghouston.com/2019/02/">February 3, 2019</a></span>
<span class="entry-meta-author author vcard"><i class="fa fa-user"></i><a class="fn" href="https://www.bloghouston.com/author/kevin/">Kevin Whited</a></span>
<span class="entry-meta-categories"><i class="fa fa-folder-open-o"></i><a href="https://www.bloghouston.com/section/linkposts/" rel="category tag">Around The Web</a></span>
</div>
	<div class="mh-posts-grid-excerpt clearfix">
		<div class="mh-excerpt"><p>In this edition of the weekend brunch: HPD raid raises questions that need answers, the Houston area&#8217;s pay-to-play political culture continues to get scrutiny, the Harris County GOP steps in it, and more! <a class="mh-excerpt-more" href="https://www.bloghouston.com/2019/02/weekend-brunch-for-3-february-2019/" title="Weekend brunch for 3 February 2019"></a></p>
</div>	</div>
</article></div>
</div>
</section>
<div id="vanilla-comments"></div>
<script type="text/javascript">
var vanilla_forum_url = 'https://www.bloghouston.com/forum'; // Required: the full http url & path to your vanilla forum
var vanilla_identifier = '11322'; // Required: your unique identifier for the content being commented on
var vanilla_url = 'https://www.bloghouston.com/2020/07/weekend-brunch-for-5-july-2020/'; // Current page's url
var vanilla_category_id = '7'; // Embed comments in this category
(function() {
	var vanilla = document.createElement('script');
	vanilla.type = 'text/javascript';
	var timestamp = new Date().getTime();
	vanilla.src = vanilla_forum_url + '/js/embed.js';
	(document.getElementsByTagName('head')[0] || document.getElementsByTagName('body')[0]).appendChild(vanilla);
})();
</script>
<noscript>Please enable JavaScript to view the <a href="http://vanillaforums.com/?ref_noscript">comments powered by Vanilla.</a></noscript>
<div class="vanilla-credit"><a class="vanilla-anchor" href="http://vanillaforums.com">Comments by <span class="vanilla-logo">Vanilla</span></a></div>
		</div>
			<aside class="mh-widget-col-1 mh-sidebar" itemscope="itemscope" itemtype="https://schema.org/WPSideBar"><div id="zoom-social-icons-widget-3" class="mh-widget zoom-social-icons-widget"><h4 class="mh-widget-title"><span class="mh-widget-title-inner">Stay Connected</span></h4>
        
        <ul class="zoom-social-icons-list zoom-social-icons-list--with-canvas zoom-social-icons-list--rounded zoom-social-icons-list--no-labels">

            
                                <li class="zoom-social_icons-list__item">
                    <a class="zoom-social_icons-list__link"
                       href="https://fb.me/blogHOUSTON"  >
                                                                        
                                                    <span class="screen-reader-text">facebook</span>
                        
                        <span class="zoom-social_icons-list-span socicon socicon-facebook" data-hover-rule="background-color" data-hover-color="#3b5998" style="background-color : #3b5998; font-size: 36px; padding:4px" ></span>

                                            </a>
                </li>

            
                                <li class="zoom-social_icons-list__item">
                    <a class="zoom-social_icons-list__link"
                       href="https://twitter.com/blogHOUSTON"  >
                                                                        
                                                    <span class="screen-reader-text">twitter</span>
                        
                        <span class="zoom-social_icons-list-span socicon socicon-twitter" data-hover-rule="background-color" data-hover-color="#55acee" style="background-color : #55acee; font-size: 36px; padding:4px" ></span>

                                            </a>
                </li>

            
                                <li class="zoom-social_icons-list__item">
                    <a class="zoom-social_icons-list__link"
                       href="https://www.linkedin.com/company/18929729"  >
                                                                        
                                                    <span class="screen-reader-text">linkedin</span>
                        
                        <span class="zoom-social_icons-list-span socicon socicon-linkedin" data-hover-rule="background-color" data-hover-color="#3371b7" style="background-color : #3371b7; font-size: 36px; padding:4px" ></span>

                                            </a>
                </li>

            
                                <li class="zoom-social_icons-list__item">
                    <a class="zoom-social_icons-list__link"
                       href="https://feeds.feedburner.com/bHmain"  >
                                                                        
                                                    <span class="screen-reader-text">rss</span>
                        
                        <span class="zoom-social_icons-list-span dashicons dashicons-rss" data-hover-rule="background-color" data-hover-color="#ff7f00" style="background-color : #ff7f00; font-size: 36px; padding:4px" ></span>

                                            </a>
                </li>

            
                                <li class="zoom-social_icons-list__item">
                    <a class="zoom-social_icons-list__link"
                       href="https://www.bloghouston.com/subscribe"  >
                                                                        
                                                    <span class="screen-reader-text">mail</span>
                        
                        <span class="zoom-social_icons-list-span socicon socicon-mail" data-hover-rule="background-color" data-hover-color="#69bf2b" style="background-color : #54a806; font-size: 36px; padding:4px" ></span>

                                            </a>
                </li>

            
        </ul>

        </div><div id="mh_magazine_custom_posts-5" class="mh-widget mh_magazine_custom_posts"><h4 class="mh-widget-title"><span class="mh-widget-title-inner">Latest Publications</span></h4>			<ul class="mh-custom-posts-widget mh-custom-posts-no-image clearfix"> 						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-11322 post type-post status-publish format-standard has-post-thumbnail category-linkposts tag-7815-harding-st-raid tag-art-acevedo tag-covid-19 tag-gerald-goines tag-greg-abbott tag-harding-street-massacre tag-houston-fire-department tag-hpd tag-hpd-narcotics-audit tag-leticia-plummer tag-lina-hidalgo tag-sylvester-turner">
														<div class="mh-custom-posts-header">
								<div class="mh-custom-posts-small-title">
									<a href="https://www.bloghouston.com/2020/07/weekend-brunch-for-5-july-2020/" title="Weekend brunch for 5 July 2020">
										Weekend brunch for 5 July 2020									</a>
								</div>
								<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://www.bloghouston.com/2020/07/">July 5, 2020</a></span>
</div>
							</div>
						</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-11309 post type-post status-publish format-standard has-post-thumbnail category-linkposts tag-covid-19 tag-greg-abbott tag-har tag-houston-police tag-houtopia tag-hpd tag-lina-hidalgo">
														<div class="mh-custom-posts-header">
								<div class="mh-custom-posts-small-title">
									<a href="https://www.bloghouston.com/2020/06/weekend-brunch-for-28-june-2020/" title="Weekend brunch for 28 June 2020">
										Weekend brunch for 28 June 2020									</a>
								</div>
								<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://www.bloghouston.com/2020/06/">June 28, 2020</a></span>
</div>
							</div>
						</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-11291 post type-post status-publish format-standard has-post-thumbnail category-linkposts tag-art-acevedo tag-coronavirus tag-coronavirus-2019_ncov tag-covid-19 tag-george-floyd tag-hpd tag-mask tag-nicolas-chavez tag-police-reform">
														<div class="mh-custom-posts-header">
								<div class="mh-custom-posts-small-title">
									<a href="https://www.bloghouston.com/2020/06/weekend-brunch-for-21-june-2020/" title="Weekend brunch for 21 June 2020">
										Weekend brunch for 21 June 2020									</a>
								</div>
								<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://www.bloghouston.com/2020/06/">June 21, 2020</a></span>
</div>
							</div>
						</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-11277 post type-post status-publish format-standard has-post-thumbnail category-linkposts tag-art-acevedo tag-chris-tomlinson tag-covid-19 tag-flood-control tag-george-floyd tag-gerald-goines tag-harding-street-massacre tag-harris-county tag-harvey tag-keith-nielsen tag-kim-ogg tag-lina-hidalgo tag-mike-snyder tag-police-reform tag-sylvester-turner tag-sylvia-garcia tag-threat-level-indicator">
														<div class="mh-custom-posts-header">
								<div class="mh-custom-posts-small-title">
									<a href="https://www.bloghouston.com/2020/06/weekend-brunch-for-14-june-2020/" title="Weekend brunch for 14 June 2020">
										Weekend brunch for 14 June 2020									</a>
								</div>
								<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://www.bloghouston.com/2020/06/">June 14, 2020</a></span>
</div>
							</div>
						</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-11260 post type-post status-publish format-standard has-post-thumbnail category-linkposts tag-art-acevedo tag-covid-19 tag-crew-demo-2-mission tag-gene-wu tag-george-floyd tag-glo tag-harvey tag-houston-chronicle tag-lockdowns tag-nasa tag-spacex tag-stan-stanart tag-sylvester-turner">
														<div class="mh-custom-posts-header">
								<div class="mh-custom-posts-small-title">
									<a href="https://www.bloghouston.com/2020/05/weekend-brunch-for-31-may-2020/" title="Weekend brunch for 31 May 2020">
										Weekend brunch for 31 May 2020									</a>
								</div>
								<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://www.bloghouston.com/2020/05/">May 31, 2020</a></span>
</div>
							</div>
						</li>			</ul></div>	</aside>	</div>
    </div>
<footer class="mh-footer" itemscope="itemscope" itemtype="https://schema.org/WPFooter">
<div class="mh-container mh-container-inner mh-footer-widgets mh-row clearfix">
<div class="mh-col-1-4 mh-widget-col-1 mh-footer-4-cols  mh-footer-area mh-footer-1">
<div id="custom_html-2" class="widget_text mh-footer-widget widget_custom_html"><div class="textwidget custom-html-widget"><br />
blogHOUSTON is an independent source for commentary on Houston-area politics, media, and culture.</div></div></div>
<div class="mh-col-1-4 mh-widget-col-1 mh-footer-4-cols  mh-footer-area mh-footer-2">
<div id="custom_html-3" class="widget_text mh-footer-widget widget_custom_html"><div class="textwidget custom-html-widget"></div></div></div>
<div class="mh-col-1-4 mh-widget-col-1 mh-footer-4-cols  mh-footer-area mh-footer-3">
<div id="custom_html-4" class="widget_text mh-footer-widget widget_custom_html"><div class="textwidget custom-html-widget"></div></div></div>
<div class="mh-col-1-4 mh-widget-col-1 mh-footer-4-cols  mh-footer-area mh-footer-4">
<div id="custom_html-5" class="widget_text mh-footer-widget widget_custom_html"><div class="textwidget custom-html-widget"><b>CONTACT INFORMATION</b><br />
blogHOUSTON<br />
PO Box 631424<br />
Houston, TX 77263<br />
<a href="mailto:blogHOUSTON+f@gmail.com"><u>blogHOUSTON@gmail.com</u></a></div></div></div>
</div>
</footer>
<div class="mh-copyright-wrap">
	<div class="mh-container mh-container-inner clearfix">
		<p class="mh-copyright">
			Copyright © 2004-2020, blogHOUSTON		</p>
	</div>
</div>
<a href="#" class="mh-back-to-top"><i class="fa fa-chevron-up"></i></a>
</div><!-- .mh-container-outer -->
        <script type="text/javascript">
        var vanilla_forum_url = 'https://www.bloghouston.com/forum';
        (function() {
            var vanilla_count = document.createElement('script');
            vanilla_count.type = 'text/javascript';
            vanilla_count.src = vanilla_forum_url + '/js/count.js';
            (document.getElementsByTagName('head')[0] || document.getElementsByTagName('body')[0]).appendChild(vanilla_count);
        })();
        </script>
    
<!-- WP Socializer 5.2.1 - JS - Start -->
<script>var wpsr_ajax_url = "https://www.bloghouston.com/wp-admin/admin-ajax.php";</script>
<!-- WP Socializer - JS - End -->
        <script type="text/javascript">
            (function(){
                document.addEventListener('DOMContentLoaded', function(){
                    let wpp_widgets = document.querySelectorAll('.popular-posts-sr');

                    if ( wpp_widgets ) {
                        for (let i = 0; i < wpp_widgets.length; i++) {
                            let wpp_widget = wpp_widgets[i];
                            WordPressPopularPosts.theme(wpp_widget);
                        }
                    }
                });
            })();
        </script>
                <script>
            var WPPImageObserver = null;

            function wpp_load_img(img) {
                if ( ! 'imgSrc' in img.dataset || ! img.dataset.imgSrc )
                    return;

                img.src = img.dataset.imgSrc;

                if ( 'imgSrcset' in img.dataset ) {
                    img.srcset = img.dataset.imgSrcset;
                    img.removeAttribute('data-img-srcset');
                }

                img.classList.remove('wpp-lazyload');
                img.removeAttribute('data-img-src');
                img.classList.add('wpp-lazyloaded');
            }

            function wpp_observe_imgs(){
                let wpp_images = document.querySelectorAll('img.wpp-lazyload'),
                    wpp_widgets = document.querySelectorAll('.popular-posts-sr');

                if ( wpp_images.length || wpp_widgets.length ) {
                    if ( 'IntersectionObserver' in window ) {
                        WPPImageObserver = new IntersectionObserver(function(entries, observer) {
                            entries.forEach(function(entry) {
                                if (entry.isIntersecting) {
                                    let img = entry.target;
                                    wpp_load_img(img);
                                    WPPImageObserver.unobserve(img);
                                }
                            });
                        });

                        if ( wpp_images.length ) {
                            wpp_images.forEach(function(image) {
                                WPPImageObserver.observe(image);
                            });
                        }

                        if ( wpp_widgets.length ) {
                            for (var i = 0; i < wpp_widgets.length; i++) {
                                let wpp_widget_images = wpp_widgets[i].querySelectorAll('img.wpp-lazyload');

                                if ( ! wpp_widget_images.length && wpp_widgets[i].shadowRoot ) {
                                    wpp_widget_images = wpp_widgets[i].shadowRoot.querySelectorAll('img.wpp-lazyload');
                                }

                                if ( wpp_widget_images.length ) {
                                    wpp_widget_images.forEach(function(image) {
                                        WPPImageObserver.observe(image);
                                    });
                                }
                            }
                        }
                    } /** Fallback for older browsers */
                    else {
                        if ( wpp_images.length ) {
                            for (var i = 0; i < wpp_images.length; i++) {
                                wpp_load_img(wpp_images[i]);
                                wpp_images[i].classList.remove('wpp-lazyloaded');
                            }
                        }

                        if ( wpp_widgets.length ) {
                            for (var j = 0; j < wpp_widgets.length; j++) {
                                let wpp_widget = wpp_widgets[j],
                                    wpp_widget_images = wpp_widget.querySelectorAll('img.wpp-lazyload');

                                if ( ! wpp_widget_images.length && wpp_widget.shadowRoot ) {
                                    wpp_widget_images = wpp_widget.shadowRoot.querySelectorAll('img.wpp-lazyload');
                                }

                                if ( wpp_widget_images.length ) {
                                    for (var k = 0; k < wpp_widget_images.length; k++) {
                                        wpp_load_img(wpp_widget_images[k]);
                                        wpp_widget_images[k].classList.remove('wpp-lazyloaded');
                                    }
                                }
                            }
                        }
                    }
                }
            }

            document.addEventListener('DOMContentLoaded', function() {
                wpp_observe_imgs();

                // When an ajaxified WPP widget loads,
                // Lazy load its images
                document.addEventListener('wpp-onload', function(){
                    wpp_observe_imgs();
                });
            });
        </script>
        <script type='text/javascript' src='https://www.bloghouston.com/wp-includes/js/jquery/ui/core.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://www.bloghouston.com/wp-content/plugins/stopbadbots/assets/js/stopbadbots_fingerprint.js'></script>
<script type='text/javascript' src='https://www.bloghouston.com/wp-content/plugins/stopbadbots/assets/js/stopbadbots.js'></script>
<script type='text/javascript' src='https://www.bloghouston.com/wp-includes/js/comment-reply.min.js?ver=9b6543cf57294487a3cc8e05eb1d1e8a'></script>
<script type='text/javascript' src='https://www.bloghouston.com/wp-content/plugins/social-icons-widget-by-wpzoom/assets/js/social-icons-widget-frontend.js?ver=1586739947'></script>
<script type='text/javascript' src='https://www.bloghouston.com/wp-includes/js/wp-embed.min.js?ver=9b6543cf57294487a3cc8e05eb1d1e8a'></script>
<script type='text/javascript' src='https://www.bloghouston.com/wp-content/plugins/wp-socializer/public/js/wp-socializer.min.js?ver=5.2.1'></script>
</body>
</html>